<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic I answer my own question, it in Intel® MPI Library</title>
    <link>https://community.intel.com/t5/Intel-MPI-Library/Using-Intel-MPI-with-PBSPro-and-Kerberos/m-p/1176192#M6646</link>
    <description>&lt;P&gt;I answer my own question, it appears the solution lies in PBSPro User Guide §6.2.6.1.&lt;/P&gt;

&lt;P&gt;Setting&lt;/P&gt;

&lt;PRE class="brush:bash;"&gt;export I_MPI_HYDRA_BOOTSTRAP=rsh
export I_MPI_HYDRA_BOOTSTRAP_EXEC=pbs_tmrsh&lt;/PRE&gt;

&lt;P&gt;fixed my issue. I was mislead by the fact we don't have `rsh` installed.&lt;/P&gt;</description>
    <pubDate>Mon, 04 Sep 2017 11:50:00 GMT</pubDate>
    <dc:creator>Luc_H_</dc:creator>
    <dc:date>2017-09-04T11:50:00Z</dc:date>
    <item>
      <title>Using Intel MPI with PBSPro and Kerberos</title>
      <link>https://community.intel.com/t5/Intel-MPI-Library/Using-Intel-MPI-with-PBSPro-and-Kerberos/m-p/1176191#M6645</link>
      <description>&lt;P&gt;Hello,&lt;/P&gt;

&lt;P&gt;We have some troubles on our cluster to use Intel MPI with PBSPro under a Kerberized environment.&lt;/P&gt;

&lt;P&gt;The thing is PBSPro doesn't forward Kerberos tickets which prevents us to have a password-less ssh. Security officers rejects ssh keys without a passphrase, beside, we are expected to rely on Kerberos in order to connect through ssh.&lt;/P&gt;

&lt;P&gt;As you can expect, a simple&lt;/P&gt;

&lt;PRE class="brush:bash;"&gt;mpirun -l -v -n $nb_procs "${PBS_O_WORKDIR}/echo-node.sh" # that simply calls bash builtin echo&lt;/PRE&gt;

&lt;P&gt;fails because of pmi_proxy that hangs, and in the end the walltime is exceeded, and we observe:&lt;/P&gt;

&lt;PRE class="brush:plain;"&gt;[...]
[mpiexec@node028.sis.cnes.fr] Launch arguments: /work/logiciels/rhall/intel/parallel_studio_xe_2017_u2/compilers_and_libraries_2017.2.174/linux/mpi/intel64/bin/pmi_proxy --control-port node028.sis.cnes.fr:41735 --debug --pmi-connect alltoall --pmi-aggregate -s 0 --rmk pbs --launcher ssh --demux poll --pgid 0 --enable-stdin 1 --retries 10 --control-code 1939201911 --usize -2 --proxy-id 0
[mpiexec@node028.sis.cnes.fr] Launch arguments: /bin/ssh -x -q node029.sis.cnes.fr /work/logiciels/rhall/intel/parallel_studio_xe_2017_u2/compilers_and_libraries_2017.2.174/linux/mpi/intel64/bin/pmi_proxy --control-port node028.sis.cnes.fr:41735 --debug --pmi-connect alltoall --pmi-aggregate -s 0 --rmk pbs --launcher ssh --demux poll --pgid 0 --enable-stdin 1 --retries 10 --control-code 1939201911 --usize -2 --proxy-id 1
[proxy:0:0@node028.sis.cnes.fr] Start PMI_proxy 0
[proxy:0:0@node028.sis.cnes.fr] STDIN will be redirected to 1 fd(s): 17
[0] node: 0 /  /
=&amp;gt;&amp;gt; PBS: job killed: walltime 23 exceeded limit 15
[mpiexec@node028.sis.cnes.fr] HYDU_sock_write (../../utils/sock/sock.c:418): write error (Bad file descriptor)
[mpiexec@node028.sis.cnes.fr] HYD_pmcd_pmiserv_send_signal (../../pm/pmiserv/pmiserv_cb.c:252): unable to write data to proxy
[mpiexec@node028.sis.cnes.fr] ui_cmd_cb (../../pm/pmiserv/pmiserv_pmci.c:174): unable to send signal downstream
[mpiexec@node028.sis.cnes.fr] HYDT_dmxu_poll_wait_for_event (../../tools/demux/demux_poll.c:76): callback returned error status
[mpiexec@node028.sis.cnes.fr] HYD_pmci_wait_for_completion (../../pm/pmiserv/pmiserv_pmci.c:501): error waiting for event
[mpiexec@node028.sis.cnes.fr] main (../../ui/mpich/mpiexec.c:1147): process manager error waiting for completion
&lt;/PRE&gt;

&lt;P&gt;If instead we log onto the &lt;EM&gt;master&lt;/EM&gt; node, execute kinit, and then run mpirun, everything works fine. Except this isn't exactly an acceptable workaround.&lt;/P&gt;

&lt;P&gt;I've tried to play with the fabrics as the nodes are also connected with infiband, but I had no luck there. If I'm not mistaken, pmi_proxy does require password-less ssh whatever fabrics we have. Am I right ?&lt;/P&gt;

&lt;P&gt;BTW, I've also tried to play with Altair PBSPro's pbsdsh. I've observed that the parameters it expects are not compatible with the one fed by mpirun. Besides, even if I encapsulate pbsdsh, pmi_proxy still fails with a&lt;/P&gt;

&lt;PRE class="brush:plain;"&gt;[proxy:0:0@node028.sis.cnes.fr] HYDU_sock_connect (../../utils/sock/sock.c:268): unable to connect from "node028.sis.cnes.fr" to "node028.sis.cnes.fr" (Connection refused)
[proxy:0:0@node028.sis.cnes.fr] main (../../pm/pmiserv/pmip.c:461): unable to connect to server node028.sis.cnes.fr at port 49813 (check for firewalls!)
&lt;/PRE&gt;

&lt;P&gt;So. My question, is there a workaround? Something that I've missed? Every clue I can gather googling and experimenting points me towards "password-less ssh". So far the only workaround we've found consist in using another MPI framework :(&lt;/P&gt;

&lt;P&gt;Regards,&lt;/P&gt;</description>
      <pubDate>Fri, 01 Sep 2017 16:11:12 GMT</pubDate>
      <guid>https://community.intel.com/t5/Intel-MPI-Library/Using-Intel-MPI-with-PBSPro-and-Kerberos/m-p/1176191#M6645</guid>
      <dc:creator>Luc_H_</dc:creator>
      <dc:date>2017-09-01T16:11:12Z</dc:date>
    </item>
    <item>
      <title>I answer my own question, it</title>
      <link>https://community.intel.com/t5/Intel-MPI-Library/Using-Intel-MPI-with-PBSPro-and-Kerberos/m-p/1176192#M6646</link>
      <description>&lt;P&gt;I answer my own question, it appears the solution lies in PBSPro User Guide §6.2.6.1.&lt;/P&gt;

&lt;P&gt;Setting&lt;/P&gt;

&lt;PRE class="brush:bash;"&gt;export I_MPI_HYDRA_BOOTSTRAP=rsh
export I_MPI_HYDRA_BOOTSTRAP_EXEC=pbs_tmrsh&lt;/PRE&gt;

&lt;P&gt;fixed my issue. I was mislead by the fact we don't have `rsh` installed.&lt;/P&gt;</description>
      <pubDate>Mon, 04 Sep 2017 11:50:00 GMT</pubDate>
      <guid>https://community.intel.com/t5/Intel-MPI-Library/Using-Intel-MPI-with-PBSPro-and-Kerberos/m-p/1176192#M6646</guid>
      <dc:creator>Luc_H_</dc:creator>
      <dc:date>2017-09-04T11:50:00Z</dc:date>
    </item>
  </channel>
</rss>

