<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Event viewer error with RCS remote configuration in Intel vPro® Platform</title>
    <link>https://community.intel.com/t5/Intel-vPro-Platform/Event-viewer-error-with-RCS-remote-configuration/m-p/550962#M6384</link>
    <description>&lt;P&gt;So I've made an RCS/SCS server, set up the database and CA, set up the DNS, etc but still running into issues when the server-script .bat/.vbs script is called by the scs software.&lt;/P&gt;&lt;P&gt;WMI works to the remote system, I can query for domain name and see the results in the log file. &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;it's the part of the script which calls ConfigAMT which fails. &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;retVal = objWMIService.ConfigAMT(uuid, fqdn, ConfMethod, profileName, pid, "", "", "", "", strComputer, "", "", "", "", "", "", "", errorStr)&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt; fqdn, uuid, strComputer, all reflect the test PC's fqdn, uuid, and IP address respectively. That was obviously the intent of the sample scripts.  ConfMethod is 2 (PKI), profile name is "CSIT_Managed" which matches a profile I defined in scs. errorStr is always returned empty. &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;All the variables and their values appear to be correct, but I get an erroneous return value of -1073741718 and in the windows event viewer I see this message:&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;The following information was included with the event: &lt;/P&gt;&lt;P&gt;Method call ConfigAMT is denied because computer SERVERNAME$ made the call for &lt;A href="http://PCNAME.DOMAIN.CA"&gt;PCNAME.DOMAIN.CA&lt;/A&gt; instead of for itself.&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;I do not understand where the error is coming from, the error makes no sense.... isn't the whole point for RCS is that the SERVERNAME$ can make a call to provision &lt;A href="http://PCNAME.DOMAIN.CA"&gt;PCNAME.DOMAIN.CA&lt;/A&gt;?&lt;/P&gt;</description>
    <pubDate>Tue, 21 Nov 2017 16:42:50 GMT</pubDate>
    <dc:creator>ZShav</dc:creator>
    <dc:date>2017-11-21T16:42:50Z</dc:date>
    <item>
      <title>Event viewer error with RCS remote configuration</title>
      <link>https://community.intel.com/t5/Intel-vPro-Platform/Event-viewer-error-with-RCS-remote-configuration/m-p/550962#M6384</link>
      <description>&lt;P&gt;So I've made an RCS/SCS server, set up the database and CA, set up the DNS, etc but still running into issues when the server-script .bat/.vbs script is called by the scs software.&lt;/P&gt;&lt;P&gt;WMI works to the remote system, I can query for domain name and see the results in the log file. &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;it's the part of the script which calls ConfigAMT which fails. &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;retVal = objWMIService.ConfigAMT(uuid, fqdn, ConfMethod, profileName, pid, "", "", "", "", strComputer, "", "", "", "", "", "", "", errorStr)&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt; fqdn, uuid, strComputer, all reflect the test PC's fqdn, uuid, and IP address respectively. That was obviously the intent of the sample scripts.  ConfMethod is 2 (PKI), profile name is "CSIT_Managed" which matches a profile I defined in scs. errorStr is always returned empty. &lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;All the variables and their values appear to be correct, but I get an erroneous return value of -1073741718 and in the windows event viewer I see this message:&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;The following information was included with the event: &lt;/P&gt;&lt;P&gt;Method call ConfigAMT is denied because computer SERVERNAME$ made the call for &lt;A href="http://PCNAME.DOMAIN.CA"&gt;PCNAME.DOMAIN.CA&lt;/A&gt; instead of for itself.&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;&lt;/P&gt;&lt;P&gt;I do not understand where the error is coming from, the error makes no sense.... isn't the whole point for RCS is that the SERVERNAME$ can make a call to provision &lt;A href="http://PCNAME.DOMAIN.CA"&gt;PCNAME.DOMAIN.CA&lt;/A&gt;?&lt;/P&gt;</description>
      <pubDate>Tue, 21 Nov 2017 16:42:50 GMT</pubDate>
      <guid>https://community.intel.com/t5/Intel-vPro-Platform/Event-viewer-error-with-RCS-remote-configuration/m-p/550962#M6384</guid>
      <dc:creator>ZShav</dc:creator>
      <dc:date>2017-11-21T16:42:50Z</dc:date>
    </item>
    <item>
      <title>Re: Event viewer error with RCS remote configuration</title>
      <link>https://community.intel.com/t5/Intel-vPro-Platform/Event-viewer-error-with-RCS-remote-configuration/m-p/550963#M6385</link>
      <description>&lt;P&gt;Hello,&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;RCS has a relatively new code that locks configurations by default from a computer account from a different computer.  In this case you'd only be able to configure your computer.  If on Computer 1, then computer 1 can configure but Computer 2 cannot.  There is an option to change this behavior.  ConfigAMT is &lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;HKLM/Software/WOW64(32)node/Intel/Intel Setup and Configuration Software/11.2/RCS/General Settings&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;Key: EnhancedSecurityEnabled &lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;Value: 01 (default) so, change to 00.&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;The other workaround (assuming you are using an account that is a local account) to use an account that has local admin rights to the AMT computer and appropriate rights to Intel_RCS NameSpace.&lt;P&gt;&amp;nbsp;&lt;/P&gt;&lt;P&gt;&amp;nbsp;&lt;/P&gt;Regards,&lt;P&gt;&amp;nbsp;&lt;/P&gt;Michael</description>
      <pubDate>Thu, 30 Nov 2017 22:38:34 GMT</pubDate>
      <guid>https://community.intel.com/t5/Intel-vPro-Platform/Event-viewer-error-with-RCS-remote-configuration/m-p/550963#M6385</guid>
      <dc:creator>idata</dc:creator>
      <dc:date>2017-11-30T22:38:34Z</dc:date>
    </item>
  </channel>
</rss>

