Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4679 Discussions

127 Error in Intel Parallel Studio XE 2013 for icc compiled code

Amol_K_
Beginner
215 Views

I've a simple c program for which I want to use Advisor Studio XE 2013. Code is something like

#include "stdio.h"
#include<omp.h>
int main (int argc, char *argv[])
{
double tic=omp_get_wtime();
long unsigned int i,bn=100000000;
	for (i = 0; i < bn; i += 1)
	{
		printf("%lu ",i);
	}
	printf("\nTime = %lfs",omp_get_wtime()-tic);
	
	return 0;
}

I've set variables in $PATH and $LD_LIBRARY_PATH and also I did something like :

source /opt/intel/composerxe/bin/compilervars.sh intel64
source /opt/intel/vtune_amplifier_xe/amplxe-vars.sh
source /opt/intel/inspector_xe/inspxe-vars.sh

For compiling code (I know I'm repeating -I option):

 /opt/intel/bin/icc counter.c -o $ctr_icc -openmp -O2 -ldl -g -I "/opt/intel/advisor_xe_2013/include" -I "/opt/intel/include/" 

It worked very well and gave ctr_icc file which runs perfectly well on terminal.
Now I'm using advisor gui and importing ctr_icc with working directory and output directory. But its giving me error code 127 (which stands for Path/Application not found) with error "No Data error code 0x4000001e". My collector log is :
 

Collection has been started.
Collection has stopped. Application exit code:  127
Finalizing results
Finalizing the result
Clearing the database
The database has been cleared, elapsed time is 0.243 seconds.
Loading raw data to the database
Raw data has been loaded to the database, elapsed time is 0.001 seconds.
Finalizing the result took 0.251 seconds.

Note that I've set Env_variable for ICC compiler and changed ptrace value from 1 to 0. I've even tried with something like

advixe-cl --collect correctness --project-dir /home/src/advi/ --search-dir src:r=/home/src/ /home/src/ctr_icc

 

0 Kudos
1 Reply
Kevin_O_Intel1
Employee
215 Views

 

Hi,

Can you zip up the result and send them to me.

Under your Intel Advisor XE project you should see a directory of the form e000. If you can send this it would assist us in debugging the issue. Thanks!

Kevin 

Reply