Community
cancel
Showing results for 
Search instead for 
Did you mean: 
nengneng
Beginner
136 Views

After installing,i can't run /opt/intel/vtune/bin/vtl!help me

when i run vtl and Activitycontrol, there is an error :"NTD is not runnig at the moment,please start it before using NT services" .what's the problem?Havei successfully installed vtune?what is NTD ? please give me a hand !thanks!
0 Kudos
6 Replies
136 Views

nengneng,
The best way to know how vtune installed is to read the installation log file, default location:
/var/opt/install.log
That log shows all user choices, all installation successes and failures, along with date and time stamps.Check for failures and let's see what's what, there.
Do you remember if you did a "custom" or a "typical" install? Sounds like you may have picked "custom. Those needed ntd services are configured to start up any time the server goes into multiuser mode in a typical install.
If you did a custom install and said you'd launch those services manually, you'll have to do it manually. (The scripts for automating daemons at system state changes are in /etc/rc.d/init.d, and a script named "vtune" gets added in there during a normal install).
OR, if you're in a hurry: just uninstall vtune and reinstall using a "typical" install. Sounds like you may have done a "custom" install, yes?
No matter what, report back here with what you find.
cheers
jdg
nengneng
Beginner
136 Views

acctually , i haven't installed vtune successfully. when i run ./install ,there are four choices.1 2 3 4,i chose 1 which installs " All VTune Performance Analyzer 2.0 for Linux* components ". the "EntireX DCOM for Linux" and "VTune Performance Analyzer Driver Kit" have installed successfully,but the last that is "VTune Performance Analyzer 2.0 for Linux" failed. the info as follows:


VTune Performance Analyzer 2.0 for Linux* is being installed...


The install destination has been set to /opt/intel/vtune


install.sh: line 389: [: ??: integer expression expected
Registering VTune Performance Analyzer files, please wait...
Failed to load library /opt/intel/vtune/shared/bin/libWorkspaceMgrps.so
Failed to load library /opt/intel/vtune/shared/bin/libPropBag.so
Failed to load library /opt/intel/vtune/shared/bin/libComInfops.so
Failed to load library /opt/intel/vtune/shared/bin/libDataObjectps.so
Failed to load library /opt/intel/vtune/shared/bin/libFileCopier.so
Failed to load library /opt/intel/vtune/shared/bin/libVTRunps.so
Failed to load library /opt/intel/vtune/shared/bin/libActivity.so
Failed to load library /opt/intel/vtune/shared/bin/libFileCopierps.so
Failed to load library /opt/intel/vtune/shared/bin/libActivityps.so
Failed to load library /opt/intel/vtune/shared/bin/libCollection.so
Failed to load library /opt/intel/vtune/shared/bin/libRunCfg.so
Failed to load library /opt/intel/vtune/shared/bin/libVTRun.so
Failed to load library /opt/intel/vtune/shared/bin/libEnvInfops.so
Failed to load library /opt/intel/vtune/shared/bin/libShellTLB.so
Failed to load library /opt/intel/vtune/shared/bin/libActivityHps.so
Failed to load library /opt/intel/vtune/shared/bin/libStandardExeCtrl.so
Failed to load library /opt/intel/vtune/shared/bin/libShellps.so
Failed to load library /opt/intel/vtune/shared/bin/libReports.so
Failed to load library /opt/intel/vtune/shared/bin/libFileMgr.so
Failed to load library /opt/intel/vtune/shared/bin/libDataObject.so
Failed to load library /opt/intel/vtune/shared/bin/libShell.so
Failed to load library /opt/intel/vtune/shared/bin/libvtlHandlers.so
Failed to load library /opt/intel/vtune/shared/bin/libProductInfo.so
Failed to load library /opt/intel/vtune/shared/bin/libComInfo.so
Failed to load library /opt/intel/vtune/shared/bin/libRunCfgps.so
Failed to load library /opt/intel/vtune/shared/bin/libEnvInfo.so
Failed to load library /opt/intel/vtune/shared/bin/libWorkspaceMgr.so
Failed to load library /opt/intel/vtune/shared/bin/libReportsps.so
1 Error: NTD is not running at the moment, please start it before using NT services.
error: %post(intel-vtune-cli-shell-2.0p-341) scriptlet failed, exit status 2

you said installing typically,does that mean i chose 1 or 2 or 3 or 4 ?

i just install step by step , first "EntireX DCOM for Linux", secend "VTune Performance Analyzer Driver Kit" ,last "VTune Performance Analyzer 2.0 for Linux". But there are also erros below. there is no install.log under /var/opt. i just see install.log under /var/log.

where can i choose "custom" or "typical"
David_A_Intel1
Employee
136 Views

First, you're using an older version (2.0), the currently shipping version is 3.0. I suggest you upgrade. If you are using the non-commercial version, simply return to the URL and download the new package. If you purchased the product and are within your one year of support services, log into Intel Premier Supportand download the new package. You current license enables free upgrades for one year from the date of purchase (assuming you registered your purchase). If you have an eval, return to the Eval Center and register to eval the new version.
Second, which OS are you attempting to install this on? Have you verified that the OS is supported? Check out http://www.intel.com/software/products/vtune/vlin/sysreq.htmfor version 3.0.
136 Views

DaveA is spot on, as usual.
Do not spend any time on version 2.0 of this product, and it doesn't have the installation enhancements we've been talking about. (no custom, no typical).
After you get the 3.0 software, select typical and I'm betting you'll be into some smooth sailing from there.
BE SURE to report back here and let us know what happens, either way.
cheers
jdg
nengneng
Beginner
136 Views

thanks a lot! it's quiet the problem that i use 2.0 version.i will get a 3.0 and try!:smileyhappy:
136 Views

Please report back here and let us know how it goes.
jdg
Reply