Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
98 Views

Amplier fails with "PMU resource(s) currently being used by another profiling tool or process"

I am running Amplifier cluster edition 2016 on  Intel(R) Xeon(R) CPU E7-2890 v2 @ 2.80GHz, Linux. 

After I killed a previous session of the amplxe-cl application, any attempt yo start an analysis either using "amplxe-gui" or "amplxe-cl" fails with the following error message: PMU resource(s) currently being used by another profiling tool or process:     another PMU collection session may be running.

Even after killing any leftover processes that looked like amplxe, the error does not go away. How can I ensure no instance of amplxe is running?

 

0 Kudos
2 Replies
Highlighted
Employee
98 Views

Based on your error message, ensure that you have no other tool which is using PMU resource. See below in release notes:

Running other PMU-based tools simultaneously with hardware event-based sampling
collection is not supported (200166101)
o  The Sampling Driver requires exclusive use of the PMU resources. Running multiple PMU
based tools will cause incorrect results and/or system instability.

You can refer to other thread - which had similar issue, running on MPI program?

0 Kudos
Highlighted
98 Views

Hello,

You can try:

><VTune_install_dir>/bin64/sep -stop

If it does not help - please re-load the driver: under administrative privileges run:

><VTune_install_dir>/sepdk/src/rmmod-sep

><VTune_install_dir>/sepdk/src/insmod-sep -g <vtune_group>

Thanks & Regards, Dmitry

 

0 Kudos