Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Patxi_Funes
Beginner
107 Views

Failed to finalize the result: the result you are opening is empty

I am trying to use the 'find hotspots' functionality with an attached process. Some tests have run ok. However, in the last tests this message appear: 'Failed to finalize the result: the result you are opening is empty. This may caused by an error during data collection. Try to re-run the analysis'
I am using the Intel vTune Amplfier XE 21011 Update 2 on a Windows 7 with VS2010. I have run the test projects and they have run fine.
In my test case I have seen that the data0 folder contains many .cs files but not the .trace file. I can not make another test unless I restart the attatched process.
what can cause this message?
Thank you in advance
0 Kudos
1 Reply
Rob5
New Contributor II
107 Views

Patxi,

There are numerous reason why this behavior might occur. Are you able to replicate the behavior the process you are analyzing? If so, can you

- Let us know more about the nature of the application you are attempting to analyze which is failing? Is it managed, unmanaged, or mixed? What language(s) is the application written in? What is the base language?

- Are you running analysis inside of Visual Studio?

- Are you running as Administrator?

- In the Analysis type tab, is the Collect highly accurate CPU time checkbox enabled?

- In the Analysis type tab, if you click re-resolve what is the behavior. Does the behavior change?

- What is the duration of the analysis run?

- Are you able to run lightweight hotspots on the process?

- Can you provide the Intel VTune Amplifier XE command line being ran? You can obtain the command line from Intel VTune Amplifier GUI Analysis Summary tab > and click on the Get Command Line button.

This may help narrow the scope of the issue. We may need to collect some logging, etc. however we may want to do this as a private thread after initial triage.

Thanks
Rob

Reply