Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Nav
New Contributor I
82 Views

Have glibc 2.1. Vtune installer says no.

Tried installing the evaluation version of Vtune 9.1 for Linux, on Fedora 12.

The installer says:
Checking the environment, please wait...

The following IA-32 package(s) must be installed prior to
installing the VTune Performance Analyzer 9.1 for Linux*:

glibc version 2.11 or higher

Check with your OS vendor to obtain the package(s).
Installation failed. Please press to finish.

Please see /var/log/vtune_install.log file for details

and the log file says:
Mon Oct 18 16:29:05: PREINSTALL_VTUNE_CHECK: running ./preinstall_vtune_check.sh
-+ Logging in shell wrapper is started with LOG=/var/log/vtune_install.log +-
Mon Oct 18 16:29:05: Vendor: FEDORA*. Distro: 12
Mon Oct 18 16:29:06: Package search: 'glibc' => 'version' => '2.11'
Mon Oct 18 16:29:06: Package search: 'glibc' => 'release' => '2'
Mon Oct 18 16:30:57: End script

But when I do
ldd --version

It says:

ldd (GNU libc) 2.11
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

When I already have glibc 2.11, why isn't VTune detecting it? How can I continue installation?
0 Kudos
10 Replies
Peter_W_Intel
Employee
82 Views

You can use "rpm -qa glibc*" to know what glibcversionwas installed in your system.

-Peter
Nav
New Contributor I
82 Views

This is what it says:

glibc-common-2.11-2.x86_64
glibc-devel-2.11-2.x86_64
glibc-2.11-2.x86_64
glibc-headers-2.11-2.x86_64

So if I have the right glibc version, why isn't VTune installing?

Peter_W_Intel
Employee
82 Views

Secondary, I want toverify if you are using latest product v9.1 Update 8 - which supports Fedora Core* 12.

Regards, Peter
Nav
New Contributor I
82 Views

This is the name of the tar file downloaded: VTune_91_008_lin.tar.gz
How do I check for additional info about support for FC12?
TimP
Black Belt
82 Views

The message was asking you for the 32-bit glibc development libraries. If you installed the 32-bit ("legacy development") g++, that should add those libraries. You may also need the libstdc++-33 "compatibility" libraries (possibly both 32- and 64-bit).
Nav
New Contributor I
82 Views

Okay, I don't want to mess up the libraries, so let me confirm this:
Will this 32 bit installation of glibc mess up the existing installation?

(why couldn't Linux software installation be as simple as Windows software installation!)

Nav
New Contributor I
82 Views

Okay, I don't want to mess up the libraries, so let me confirm this:
Will this 32 bit installation of glibc install without messing up the existing installation?

(why couldn't Linux software installation be as simple as Windows software installation!)

TimP
Black Belt
82 Views

Installing OpenSuSE rpm is an unlikely way to solve your problem, although it shouldn't break your installation. If you aren't an expert, a more suitable way would be to install g++ 32-bit from yum, followed by any other libraries you need.
Nav
New Contributor I
82 Views

Okay, so the problem is that Vtune is 32 bit and my OS is 64 bit. I've done a gcc installation long time back, so I know how to do it from source also.
Currently I'm working on something that needs more time than I can invest in installing VTune. Guess I'll have to do without it until I can get some time to get my hands dirty with the installation.
Thank you for your replies. Will get back to this when it won't be so much of headache just to install an evaluation version :)
Peter_W_Intel
Employee
82 Views

Now I have one box with Fedora* 12 installed (selected"Development Software" during installation)

I can reproduce this issue, because some packages were missed. I had to installthem before installingthe VTune Performance Analyzer:

1. Install glibc-2.11-2.i686.rpm and nss-softokn-freebl-3.12.4-10.fc12.i686.rpm at same time
2. Install glibc-devel-2.11-2.i686.rpm
3.Install libgcc-4.4.2-7.fc12.i686.rpm

4. Installcompat-libstdc++-33-3.2.3-68.i686.rpm
5. Install libstdc++-4.4.2-7.fc12.i686.rpm

So you can install the product smoothly, but still see some warning - said, miss other packages (libraries) for GTK, and Eclipse*...

In general, /opt/intel/bin/vtl and /opt/intel/bin/vtserver can work smoothly, but /opt/intel/bin/vtlec can't

That is all I know.

Regards, Peter

Reply