Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4682 Discussions

How to resolve "checksum mismatch" and related symbol lookup fails

don_w_
Beginner
212 Views

I've been able to run vtune several times against our target application.   But I haven't figured out how to get the symbols to go into the collected data.  For example, when I shut down the program, I see the following warnings:

amplxe: Using result path `/shared/vtune/scripts/r001hs'
amplxe: Executing actions 34 % Resolving information for `libtpsstool.so'      
amplxe: Warning: Cannot locate symbols for file `/shared/vtune/opt/intel/vtune_amplifier_xe_2013/lib64/libtpsstool.so'.
amplxe: Executing actions 34 % Resolving information for `libdl-2.5.so'        
amplxe: Warning: Cannot locate symbols for file `/lib64/libdl-2.5.so'.
amplxe: Executing actions 35 % Resolving information for `libfips.so'          
amplxe: Warning: Cannot locate symbols for file `/usr/lib64/libfips.so'.
amplxe: Executing actions 35 % Resolving information for `libc-2.5.so'         
amplxe: Warning: Cannot locate symbols for file `/lib64/libc-2.5.so'.
amplxe: Executing actions 36 % Resolving information for `libpthread-2.5.so'   
amplxe: Warning: Cannot locate symbols for file `/lib64/libpthread-2.5.so'.
amplxe: Executing actions 36 % Resolving information for `txx64.debug'         
amplxe: Warning: Cannot match file `/usr/bin/txx64.debug': checksum mismatch.
amplxe: Warning: Cannot locate symbols for file `/usr/bin/txx64.debug'.
amplxe: Executing actions 37 % Resolving information for `ld-2.5.so'           
amplxe: Warning: Cannot locate symbols for file `/lib64/ld-2.5.so'.
amplxe: Executing actions 50 % Generating a report 

The application I'm vetting is "txx64.debug" which includes debug symbols.  I'm curious what the checksum mismatch is from.  And I'm curious why it says "Cannot locate symbols for file ...txx64.debug" when I can use "strings txx64.debug" and see the symbols.

Many thanks

-d

0 Kudos
1 Reply
David_A_Intel1
Employee
212 Views

These messages are about "locating" the files.  Are you profiling /usr/bin/txx64.debug?  Is that the app, or is that a copy of the app that is an old version or something like that?  Also, have you modified the binary at all, such that a checksum value would be invalid?

The Search tab is used to tell the VTune Amplifier XE *where* files are, symbol files, binary files, source files, etc.

Reply