Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
23 Views

Intel Vtune Amplifier XE on a CentOS 5.5 Cluster

Hi,

We have a little CentOS 5.5 Cluster with intel cluster toolkit. We have discovered Vtune Amplifier XE and we are testing it at the moment (so evaluation).

I have followed the instructions and installed the "main" packages on the master. Then copied the CLI package on the nodes and installed them. So I have amplxe-gui on the master and amplxe-cl on all the nodes.

If I'm using amplxe-gui on the master to start a test, it seems to work without problem. Now I'm trying to start a test with amplxe-cl in our batch system (torque):
#!/bin/bash
#PBS -N test_OPT
#PBS -j oe
#PBS -l nodes=1:ppn=5
#PBS -l walltime=72:00:00
echo ' starting job ............................................'
amplxe-cl --collect concurrency -r r$PBS_JOBID -follow-child -no-analyze-system -- mpirun -np 5 ./program < input > output
echo ' ending job ............................................'


The job starts and creates results. I can open them with the gui. But in the output file from torque I see that:
Warning: Skipped generation of report `summary': no valid license can be found (The license is unavailable. Make sure that your license file contains the license for the req\\
uested feature. If your license requires a license server, make sure that the server is using the right license file, and you have not changed the license file since startin\\
g the server.).

How can I solve that ??? I thought that on the nodes amplxe-cl doesn't need any license ?!?

Thx a lot,
Best regards,
Guillaume

0 Kudos
2 Replies
Highlighted
Employee
23 Views

Either ignore it, or use the -no-summary option to suppress generatation of the summary report (and the warning).

By default, the -collect action performs 3 steps:
1. Data collection
2. Symbol resolution (finalization)
3. Create summary report

Step 3 is the one that requires the license (and causes the warning message). Even with the warning, the first two steps are performed.
0 Kudos
Highlighted
23 Views

Thx Mark! the -no-summary option does the job!

Bye

0 Kudos