Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Rama__Fani
Beginner
137 Views

Issue with vtune drivers being group permissioned

Hi,

To facilitate usage of vtune among a couple of people, I have changed the group ownership of vtune drivers (/dev/{pax,socperf,sep5}) from vtune to some other group (mygroup). This was done via : insmod-sep -g mygroup when loading the driver

On RHEL 7.6 dev host, I'm having issue where if this `mygroup` is not the primary group of the user, then vtune-gui and vtune is unable to run properly and query the HW sampling drivers. 

This does not seem to be an issue on RHEL 6.x. 

straces seem inconclusive yet why vtune driver being group permissioned (perm 660 and ownership of root:mygroup) and user having group membership (primary_group, mygroup) does't work. 

If I make the /dev/{pax,socperf,sep5} be root:primary_group, then it works.But making it root:mygroup fails on RHEL 7.x only

Any reason why? Something to do with sssd settings? Why is vtune not able to work with such a scenario? Any help please?

 

Thanks,

0 Kudos
5 Replies
Adweidh_Intel
Moderator
137 Views

Dear Rama,

We are checking on this with concerned team, will get back to you at the earliest.

 

Vitaly_S_Intel
Employee
137 Views

Hi Rama,

Is 'mygroup' listed in the 'id' command output run from the user?

In order to access VTune drivers by multiple people you should have added those to the 'vtune' group. Why didn't it work?

Rama__Fani
Beginner
137 Views

Hi, 

yes, `id` lists uid=<uid>(primary_group) gid=7000(vtune) 

 `groups` lists `mygroup` as well as a group user belongs to. User's primary group is still `primary_group`

 

Users are part of `vtune` group and the drivers are group vtune writeable. .

 

Rama__Fani
Beginner
137 Views

Hi,

I found the problem. We have the `vtune` group defined by a netgroup while there was a local definition of `vtune` group as well in /etc/group. 

Removing the local /etc/group's vtune entry fixes the problem as it uses the one from netgroup and it all works. 

Adweidh_Intel
Moderator
137 Views

Hi Rama,

It seems like your issue is fixed !! Shall we close this thread ?

Reply