Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Milian_W_
Beginner
161 Views

Linux: 4.0 is not a supported linux release

Hello all,

similar to this issue back then with Linux 3.0 https://software.intel.com/en-us/forums/topic/282300 I'm now greeted by the annoying error message that "4.0 is not a supported linux release". The differences to the last 3.x release are not large, so this restriction is rather annoying. Is there a way to bypass it? Or is there a beta release ready to be tested to circumvent this issue? I've tried with the latest VTune Amplifier XE 2015 Update 3 release to no avail.

thanks

0 Kudos
13 Replies
David_A_Intel1
Employee
161 Views

The install should just warn you but still continue.  After the install completes, you can cd into the sepdk/src directory and attempt to build the driver (build-driver script).  If nothing significant has changed in the kernel, then it will build.  Otherwise, it will issue errors and fail.  Try at your own risk.

Unfortunately, whether or not "The differences to the last 3.x release are not large" is irrelevant.  If changes were made to the kernel, the VTune Amplifier sampling driver usually requires changes to support the new kernel.

We attempt to release support for new Linux distros shortly after their release - we need time to be able to test on the new release, as well. ;)

Milian_W_
Beginner
161 Views

/opt/intel/vtune_amplifier_xe_2015.3.0.403110/bin64$ ./amplxe-cl -collect hotspots kwrite
amplxe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: amplxe-cl -r /opt/intel/vtune_amplifier_xe_2015.3.0.403110/bin64/r000hs -command stop.
amplxe: Error: [Instrumentation Engine]: 4.0 is not a supported linux release 
amplxe: Collection failed.
amplxe: Internal Error

As you can see I've installed it already (that is not the issue). But I cannot collect any data, VTune just refrains from doing anything here. And the hotspots collector should not require the kernel module, I didn't even try to compile that.

David_A_Intel1
Employee
161 Views

So the underlying instrumentation engine does not support the new OS.  Try "advanced-hotspots".

Milian_W_
Beginner
161 Views

Indeed, that seems to work. But the other functionality, esp. the Locks & Waits also don't work properly. I'm looking forward to a new Beta release with support for Linux 4.x then.

bye

Martin_O_
Beginner
161 Views

Building sepdk fails on Linux 4.0. At first the build script will complain that kernel version is lower than 2.6, but after bypassing it, I get an error saying that function seq_cpumask_list could not be found. Indeed, AFAICS, it was removed from the kernel. So I suppose we'll have to wait for a patch.

Milian_W_
Beginner
161 Views

Hey there,

any update on this topic? When can we expect a beta release with Linux 4.x support? This is highly annoying...

David_A_Intel1
Employee
161 Views

I'm sorry, but we can't "pre-announce" a release or support.  Please watch for information in an upcoming release.

BTW, as far as I know, there is no "official" distribution, which VTune Amplifier supports, that has been released with the 4.0 kernel.  Again, our goal is to release support for new Linux distros shortly after their release.

Jiali_P_Intel
Employee
161 Views

hello MrAnderson,

Since linux 4.x is not supported currently. May I have a list of linux version which is get supported? The latest version intel_code_builder_for_opencl_2015_ubuntu_5.0.0.62_x64/ I am using still cannot work with Linux 4.0.

Regards,

Cecilia

 

Milian_W_
Beginner
161 Views

Note also that Fedora 22 is released since a few months now which ships with a Linux 4 kernel.

Is there really no way to disable the version check? I'm cannot believe that the "simple" hot spots analysis without the kernel driver can be impacted so strongly by the move to Linux 4.x - it worked before across the 3.x release timeline just fine after all.

That the kernel module cannot be compiled OK - but this artificial version check really annoys me and my colleagues and prevents us from using VTune productively. We now have to dual boot into older Fedora just to use VTune, which is extremely annoying.

Please fix this situation.

Dmitry_P_Intel1
Employee
161 Views

Hello,

VTune Amplifier XE 2016 Gold has support of Fedora 22 official release for both driver-based and user level instrumentation based collectors.

Stay tuned.

Thanks & Regards, Dmitry

Milian_W_
Beginner
161 Views

Is there a release scheduled for this version? Or can one get access to the latest beta as a paying customer somehow?

David_A_Intel1
Employee
161 Views

Milan,

Just FYI, there is no "artificial" version check.  The 4.0 kernel changes did, indeed, break the software collectors and require an update to the pin tool.  Thus, until an update is available with the new pin tool, you cannot collect Basic Hotspots on Linux 4.0 kernels.

As Dmitry said, "stay tuned."  We expect to announce a new release with this support, shortly.

David_A_Intel1
Employee
161 Views

Hi Milan, all:

Please see my post about the release of VTune Amplifier XE 2016, which officially supports Linux* 4.0 kernels!

Reply