Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ale_x_
Beginner
80 Views

No Event-based sampling on VTune Amplifier 2013 on Microsoft Surface Pro 2

Jump to solution

Hi,

VTune Amplifier 2013 does not detect event-based sampling capabilities on Microsoft Surface Pro 2 running Windows 8.1, which has Intel Core i5 4200U.

Is this Intel Core i5 4200U lacking the Performance Monitoring Unit, or is it Windows 8.1 issues, or something else ?

Please advise.

Thanks.

0 Kudos
1 Solution
TimP
Black Belt
80 Views

Yes, my Windows 8.1 Ultrabook has I5-4200U and the bin64\amplxe-sepreg brought it to life (update 14). 

Did you run the amplxe  .bat script in order to get it running in cmd or other shell window?

View solution in original post

5 Replies
Peter_W_Intel
Employee
80 Views

In VTune(TM) Amplifier XE 2013 Update 13:

  • Support for Microsoft Windows* 8.1 operating system and integration with Microsoft* Visual Studio* 2013 IDE

What is VTune version you are using?

Can you try amplxe-sepreg​.exe under VTune Amplifier XE 2013\bin32 in cmd to check vtune driver's status? Run "amplxe-sepreg.exe -s" 

 

Peter_W_Intel
Employee
80 Views

If the driver works, you can run "amplxe-runss -event-list" to know all supported events for your running processor.

ale_x_
Beginner
80 Views

Hi Peter,

I am running VTune Amplifier XE 2013 Update 13, all drivers failed.

>amplxe-sepreg -s
Checking sepdrv3_10 driver path...FAILED
Checking sepdrv3_10 service...FAILED
Checking sepdal driver path...FAILED
Checking sepdal service...FAILED

Can you please confirm that my CPU Intel Core i5 4200U has event-based sampling support ?

 

TimP
Black Belt
81 Views

Yes, my Windows 8.1 Ultrabook has I5-4200U and the bin64\amplxe-sepreg brought it to life (update 14). 

Did you run the amplxe  .bat script in order to get it running in cmd or other shell window?

View solution in original post

ale_x_
Beginner
80 Views

All good now, it turns out all I needed to do was

amplxe-sepreg -i -v to re-install it

from

http://software.intel.com/en-us/forums/topic/388277

Reply