Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
44 Views

No SITE annotations were encountered ?

Dear All,

I have just installed parallel studio 2016 and trying to use memory access pattern analysis with intel advisor. I have added annotation to source file like:

ANNOTATE_SITE_BEGIN(read_phase1);
for (int i=0; i < nt.n_presyn; ++i) {

 ANNOTATE_ITERATION_TASK(read_task);
 .........
}
 ANNOTATE_SITE_END();

When I run the analysis with advisor I get:

advixe-cl -collect map --search-dir src:r=/home/my_src -interval=10 -mrte-mode=auto -- mpirun -n 1 app.exe

advixe: Warning: No SITE annotations were encountered, so no stride/alignment data can be reported.

What could be reason for above warning? I am sure that annotations macros are expanded properly. What could be the possible reason? 

Is there any way to force analysis of all loops? We have lots of auto-generated kernel from DSL (domain specific language) which I would like to analyse. 

 

0 Kudos
3 Replies
Highlighted
Employee
44 Views

 

One possible reason is the loop is not executing. Or executing so quickly that there are no samples in the loop.

I would first run an Advisor survey and then run a Trip count to verify if the loop is executing and how many times it is iterating.

Regards,

Kevin

0 Kudos
Highlighted
Beginner
44 Views

Thanks Kevin for quick reply. I am now executing below commands one by one from shell script:

#survey and trip counts => WORKS
time advixe-cl -collect survey --search-dir src:r=$src_path -interval=10 -mrte-mode=auto -- mpirun  -n 1 $exe -e $time -mpi -d $data_dir
time advixe-cl -collect tripcounts --search-dir src:r=$src_path -interval=10 -mrte-mode=auto -- mpirun  -n 1 $exe -e $time -mpi -d $data_dir

#generate reports => WORKS
time advixe-cl -report survey  --search-dir src:r=$src_path --format=csv -show-all-columns -report-output ./out_survey.csv
time advixe-cl -report top-down  --search-dir src:r=$src_path --format=csv -show-all-columns -report-output ./out_top-down.csv

#memory access pattern analysis:  HANGS FOREVER!
time advixe-cl -collect map --search-dir src:r=$src_path -- mpirun  -n 1 $exe -e $time -mpi -d $data_dir

I am running above analysis with single mpi rank and single openmp thread. Simulation itself is very small (few seconds only). Survey and trip count analysis finishes without any issues. But when I start map analysis, simulation hangs! (note that the simulation code has finished executing but I don't see any further messages/output).

Here is the output directory:

$ du -h
48K	./e000/mp000/data.0
20K	./e000/mp000/config
508K	./e000/mp000
8.4M	./e000/hs000/sqlite-db
304K	./e000/hs000/data.0
40K	./e000/hs000/config
428K	./e000/hs000/data.1
8.0K	./e000/hs000/archive/binaries/[vdso]/c04ed3253f33f68f4fc781675e20b369
8.0K	./e000/hs000/archive/binaries/[vdso]/4623d904e53593f6f9e8a0dea95fe4f3
20K	./e000/hs000/archive/binaries/[vdso]
24K	./e000/hs000/archive/binaries
28K	./e000/hs000/archive
9.2M	./e000/hs000
428K	./e000/trc000/data.0
20K	./e000/trc000/config
456K	./e000/trc000
11M	./e000
12M	.

Here is the list of running processes:

$ ps -aux | grep kumbhar

kumbhar  57252 11.6  0.1 12640744 126472 pts/26 Sl  Apr27  14:03 advixe-cl -collect map --search-dir src:r=/home/kumbhar/workarena/systems/jknc/repos/bbp/coreneuron -- mpirun -n 1 /home/kumbhar/workarena/systems/jknc/repos/bbp/coreneuron/build_advisor/bin/coreneuron_exec -e 1 -mpi -d /home/kumbhar/workarena/systems/jknc/repos/bbp/corebluron/tests/240_4000_bgq/newdata/hpcopt/240/

kumbhar  57361  0.1  0.0 4504820 14068 pts/26  Sl   Apr27   0:07 /opt/intel/advisor_xe_2016.0.40.402725/bin64/advixe-runtc --ui-output-format xml --ui-output-fd 6 --option-file /home/kumbhar/workarena/systems/jknc/repos/bbp/coreneuron/paper/results/vtune_manual/imp_host_mic/vtune_paper_soa_1t_2f_1t_hpcopt_x86/e000/mp000/config/runtc.options

kumbhar  57367  0.0  0.0 459328 55564 pts/26   T    Apr27   0:03 /bin/sh /opt/intel/compilers_and_libraries_2016.0.042/linux/mpi/intel64/bin/mpirun -n 1 /home/kumbhar/workarena/systems/jknc/repos/bbp/coreneuron/build_advisor/bin/coreneuron_exec -e 1 -mpi -d /home/kumbhar/workarena/systems/jknc/repos/bbp/corebluron/tests/240_4000_bgq/newdata/hpcopt/240/

Any suggestion? What could cause this?

0 Kudos
Highlighted
Employee
44 Views

 

Hi Pramod,

Some comments from our development team:

  1. Map and correctness collections analyze base process only. So in case with “No SITE annotations” message map tried to analyze mpirun and didn’t find any sites. If you want to analyze a child process you need to specify it using –executable-of-interest=process_name option

  2. The correct way to use MPI is to run advixe-cl under mpirun, and not mpirun under advixe-cl. See examples from Advisor help:

    mpirun -n 4 advixe-cl -project-dir ./advi -collect survey -- <PATH>/mpi-sample/1_mpi_sample_serial

  3. If you use source annotations for map then I’d recommend you to add –no-mark-up CLI option. Without it advixe-cl generates and uses binary annotations for all innermost loops, but you don’t need them.

Let me know if you have any additional questions!

Regards,

Kevin

0 Kudos