Community
cancel
Showing results for 
Search instead for 
Did you mean: 
van_bergen__jan
Beginner
560 Views

Processor not recognized by VTune

Whenever I try to use Hardware Event-Based Sampling in VTune, I get the following two error messages: This analysis type is not applicable to the system because VTune Amplifier cannot recognize the processor. If this is a new Intel processor, please check for an updated version of VTune Amplifier. If this is an unreleased Intel processor, please contact Online Service Center for an NDA product package. This analysis type is not applicable to the current machine microarchitecture. I'm using a laptop with an Intel Core i7-4710HQ @ 2.50GHz [Intel64 Family 6 Model 60 Stepping 3, GenuineIntel].
0 Kudos
7 Replies
Vladimir_T_Intel
Moderator
560 Views

Please take a look at this thread: https://software.intel.com/en-us/forums/intel-vtune-amplifier/topic/806896

If your system is running under a supervisor, you might have faced the same issue. 

van_bergen__jan
Beginner
560 Views

I'm using Windows

van_bergen__jan
Beginner
560 Views

When I launch sep -version I see the following output:

I'm assuming PEBS OFF (by OS security) is the issue here?

sep -version
Sampling Enabling Product version: 5.14  built on Nov 26 2019 11:44:09
SEP User Mode Version: 5.14
SEP Driver Version: 5.14
PAX Driver Version: 1.0
Platform type: 88
CPU name: Intel(R) Core(TM) Processor code named Haswell
PMU: haswell
Driver configs: Maskable Interrupt, PEBS OFF (by OS security), MULTI PEBS OFF (tracepoints not accessible)
Copyright(C) 2007-2019 Intel Corporation. All rights reserved.
David_Billinghurst
New Contributor II
560 Views

Jan,

The thread https://software.intel.com/en-us/forums/vtune/topic/827651 may be related.  In particular post #8, where sep is redirected to a file.  I asked for an update on my support ticket late on Friday.

 

van_bergen__jan
Beginner
560 Views

Yes I seem to have the same issue. When outputting to a file I get this:

Sampling Enabling Product version: 5.14  built on Nov 26 2019 11:44:09
SEP User Mode Version: 5.14 
SEP Driver Version: 5.14 
PAX Driver Version: 1.0

The cutoff point seems to be the same even.

I also ran into something else that may be related. When using User-Mode sampling I get the following error:

Cannot load data file 'C:\Users\Startklaar\Documents\Amplifier XE\Projects\Raytricca\r000hs\data.0\emon.0.emon' (Failed to read CPU topology information!).

Kirill_U_Intel
Employee
560 Views

yes. emon will be fixed in the next public release too.

sep/emon fixes will be available in oneApi beta update 4. Update will be released in the nearest days. I think you could subsrcribe on beta program and get fix.

Another way is update 1 for parallel studio. It should be available at the end of March.

If you have access to Intel® Premier Support (IPS) the fix could be provided for you directly.

Sorry for inconvenience, Kirill

 

van_bergen__jan
Beginner
560 Views

Yes using sep_no_buf.exe it works now. Thanks!

Reply