Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)
5027 Discussions

Roofline chart without rooflines



i tried collecting roofline data in a batch job at a remote system from the command-line (advisor 2018) and look at the results with the intel advisor 2018 GUI.
As the result i get a roofline chart with dots indicating loop performance, but no rooflines are contained. It seems like the benchmark values are not collected or not displayed. I attached a chart which i received.

I had tried both ways to collect the data: with the single command "advixe-cl -collect roofline" as well as the separate "collect survey" and "collect tripcounts" ones. I attached file with the respective commands, as well as the output from the cli (only for the --collect roofline).

It is alot noticable, that in the GUI distinct control elements are missing, i.e. the "Use Single-Threaded roofs" checkbox is unavailable (compare

Maybe you have any ideas, what is going wrong?



0 Kudos
1 Reply

Problem solved: i moved to a different cluster.

Sadly i can not tell exactly, what causes the problem, just that it is somehow related to the configuration, but the admin could not tell it neither. The non-working cluster was a "serial" one, which i used as currently i was only interested in sequential optimization (vectorization). Movig to a "parallel" cluster (with obviously different configuration solved the issue...

0 Kudos