Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4890 Discussions

The GUI window does not open with Ubuntu 10.04 64bit



I have just successfully installed Intel Parallel Studio XE SP1 x86-64bit on Ubuntu 10.04 64bit.However, I cannot start the GUI of the Vtune Amplifier XE.When I run "amplxe-gui" from the command line, the GUI window does not open,and the command does not return. The process amplxe-gui is using 0% CPU.Pressing Ctrl+C immediately terminates the process and returns to the command prompt.

Documentation has not helped me with this problem, and I haven't found anything in this forum. I would greatly appreciate some help!

Here are some details on my installation:

1) The Vtune product came as a part of Parallel Studio XE SP1 x86-64bit

2) I am running it on Ubuntu 10.04 64-bit, and all packages are up to date

3) I have a file /etc/profile.d/ with the following lines:

source /opt/intel/vtune_amplifier_xe/

source /opt/intel/bin/ intel64

4) Vtune's environment variables are indeed set correctly: $PATHcontains the path to amplxe-* files, thanks to sourcing

5) The user I am running as is a member of the group "vtune"

6) Command "amplxe-cl -version" gives the following:

Intel VTune Amplifier XE 2011 Update 5 (build 186533) Command Line Tool

Copyright (C) 2009-2011 Intel Corporation. All rights reserved.

7) The release notes for this version say that Ubuntu 10.04 is supported

8) Command "java -version" gives the following:

OpenJDK Runtime Environment (IcedTea6 1.9.9) (6b20-1.9.9-0ubuntu1~10.04.2)

OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)

9) An important observation: when I uninstall the Java runtime environment,the symptoms are exactly the same. However, my Java installation does work:I can run all java applications online.

Thanks in advance! I have used VTune on other systems, and it worked like a charm almost out of the box. I am banging my head against the wall trying to make it work under Ubuntu, though...
0 Kudos
3 Replies
I ran the product (Update 5) on Ubuntu 10.04 - kernel 2.6.32-21-generic,and cannot reproduce thisproblem.

Please check:
1. Did you run lightweight-hotspots? If so, can you find vtune drivers installed? "lsmod | grep sep3" & "lsmod | grep pax"
2. Verify if you can ran do in command line:
a. amplxe-cl -collect hotspots -- application, -OR-
b. amplxe-cl -collect lightweight-hotspots -- application
3. Can you open results file which are generatedfrom command line?
4. If you can do above, and uninstalling/reinstalling the product can't solve this problem, please read this article.

Regards, Peter
0 Kudos
Peter, thank you for your response!
I got it working. It was a combination of problems: my video driver was corrupted, and I was trying to start VTune in a remote desktop application (NoMachine/FreeNX). I reinstalled the video driver and started VTune on a monitor connected directly to the machine. The window opened, and everything works.
VTune still does not open a GUI window in a virtual desktop in Ubuntu. It is strange, because it works in the same remote application in RedHat, but I will investigate it later.
0 Kudos

Hello everyone,

I just installed Intel C++ Studio XE 2013 Update 3 on Ubuntu 12.04 LTS 64bits and every components works fine except for Intel VTune Amplifier.

In fact, I successfully launched the command line application, but I cannot start the GUI of the Vtune Amplifier XE.
[bash]root@myPCname:~amplxe-cl -version
Intel(R) Vtune(TM) Amplifier XE 2013 Update 5 (build 274450) Command Line Tool Copyright (C) 2009-2013 Intel Corporation. All rights reserved.[/bash]
I came to the /opt/intel/vtune_amplifier_xe_2013/bin64 directory and the "amplxe-gui" application does not seem to be here...

Notice that during installation, I had to change the "kernel.yama.ptrace_scope" value in /etc/sysctl.d/10-ptrace.conf file but no other problems were encountered.

Any ideas to help me solve this will be grateful,

0 Kudos