Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4892 Discussions

The data cannot be displayed: there is no viewport applicable for the data

I have been trying to use VTUNE to collect data (Hotspots, Concurrency, Locks and Waits) on a process tree. A server module is used to launch several other processes. I want to be able to specifiy the PID of the server module and then collect the data for the entire process tree. I am able to start the Analysis, but the analysis always fails with "Failed to finalize the result" The result you are opening is empty. This may be caused by an error during data collection. Try to re-run the analysis. (I have tried this several times to no avail). I looked in the data folder of the analysis run and there is data in the folder.

I might add that the server process does very little other than to launch the worker processes.

When I try to re-open the analysis result it is then that I get the Message "The data cannot be displayed: there is no viewport applicable for the data".


I have been able to successfully capture and analyze data on each of the child processes, but I don't seem to be able to get the process tree which is what would be most valuable.

It find very little information as to how to capture data for the child prcesses other than the obvious that can be obtained by looking at the GUI.

I find the usefulness of the VTUNE tool to be limited if I cannot perform the detailed analysis on the process tree.

It would also be useful to be able to specify the PID of the child processes. Rather than the name.
0 Kudos
4 Replies

First at all, I suggest to use run amplxe-gui, cmd for amlxe-cl and devenv for vtune integration as administrator on Windows.

You canuse VTune to launch an application which creates more child processes,then monitor application and its child processes, like as -
amplxe-cl -collect hotspots -follow-child -- application.exe

If yourservermodule alreadyisrunning, you only can attachprogram processor oneof child processes. For somemodules which is running in system mode,user-mode sampling (hotspots, concurrency, locksandwaits) doesn't work, use lightweight-hotspots instead. for example:
# amplxe-cl -collect lightweight-hotspots -duration 3600 -target-pid 26191 &
after awhile;
#amplxe-cl -command detach -r r008lh/

Regards, Peter

0 Kudos
Got it now.
Two reasons this wasn't working before:
1) I assumed that I could attach to a process and then monitor the chilld processes that it launched.
2) The original process was running as a Service under SYSTEM user.

I am now using VTUNE to launch the server process and I can monitor the child processes.
Thanks for the guidance.
0 Kudos



I am trying update15 on a VM, the host and guest are ubuntu 12.04. Iam seeing the same error when using hotspots: "The data cannot be displayed: there is no viewport applicable for the data". I tried the lightweight hotspots and got the following error:

root@virtual-machine:/opt/intel/vtune_amplifier_xe/bin64# ./amplxe-cl -collect lightweight-hotspots -duration 10 -target-pid 2691
amplxe: Warning: The analysis type 'lightweight-hotspots' is deprecated. Use 'advanced-hotspots' analysis type instead.
amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and the driver group is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.

I have the driver installed and I am running as root. The process that I need to monitor is also running as root. Any help is appreciated.








0 Kudos

Hi Dhanesh J.:

Hardware sampling, including Advanced Hotspots, is not supported on VMs because most VMs do not virtualize the performance monitoring counters. 

The release notes state:

EBS analysis within a virtual machine is supported only in VMware* Fusion* 5 virtual environment. EBS is not supported within other virtual machine environments.

0 Kudos