Community
cancel
Showing results for 
Search instead for 
Did you mean: 
chang__yitao
Beginner
211 Views

VTUNE don't enable Source/Assembly analysis

Jump to solution

Product: Intel®️ VTune™️ Amplifier update 2/update 4

Today When I use  GPU In-profiling mode, the VTUNE report a warning :"current graphics driver does not allow enable source/assembly analysis for OpenCL kernels running on intel graphics ." 

However , i try some version graphics driver, the warning still exists.

What's wrong ? thanks a lot.

 

 

PC: CPU i7 - 8700 /  GPU UHD 630

drivers:24.20.100.6287

0 Kudos
1 Solution
Egor_S_Intel1
Employee
211 Views

Hi,

It looks like the GPU driver doesn't set a flag which means that OpenCL runtime for GPU can provide debug information for OpenCL kernels. Therefore VTune shows this message and doesn't collect debug information for the kernels.
You can try to set this flag manually. You just need to add following registry values (also I've attached reg file that can do it):
HKEY_LOCAL_MACHINE\SOFTWARE\Intel\IGFX\OCL\DebugInfoSupport=dword:1
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Intel\IGFX\OCL\DebugInfoSupport=dword:1

And thank you for your report, we'll investigate why the flag is not set.
Thanks.

View solution in original post

2 Replies
Egor_S_Intel1
Employee
212 Views

Hi,

It looks like the GPU driver doesn't set a flag which means that OpenCL runtime for GPU can provide debug information for OpenCL kernels. Therefore VTune shows this message and doesn't collect debug information for the kernels.
You can try to set this flag manually. You just need to add following registry values (also I've attached reg file that can do it):
HKEY_LOCAL_MACHINE\SOFTWARE\Intel\IGFX\OCL\DebugInfoSupport=dword:1
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Intel\IGFX\OCL\DebugInfoSupport=dword:1

And thank you for your report, we'll investigate why the flag is not set.
Thanks.

View solution in original post

chang__yitao
Beginner
211 Views
Hi, Thks a lot , now it can work.
Reply