Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4963 Discussions

VTune 7.1 on Banias (Pentium M) Processor

I am attempting use VTune 7.1 in conjunction with its Linux Remote Data Collection Server (RDC) version 2.0 on a platform with the Pentium M (aka Banias) processor at 1.6GHz. It has been stated that 7.1 is compatible withe Banias CPU architecture/ microarchitecture.
Specifics of my HW/SW environments are as follow:
Linux Redhat 7.3 (Kernel 2.4.18-3)
Pentium M Processor 1.6GHz, Intel E7501 chipset
VTune 7.1 Front End on Windows XP
Linux RDC 2.0
When I connect to the RDC & start sampling while running my application (a kernel level driver in my case) on the Linux target, the Linux machine runs into a kernel PANIC soon after starting the sampling.
The Release Notes for RDC 2.0 caution thispossibliity & advise using Kernel version 2.4.18-10 with RH 7.3. I have duly tried this option as well & got the same results i.e., Kernel Panic once sampling starts on the Linux box. In a third attempt, I have also tried RH9.0 (kernel version 2.4.20-8) with the same result.
The above results are _very_ consistent across 20 runs with no exception.
If anyone has had a better or similar experience using VTune on the Banias CPU, I would appeciate sharing it here.
0 Kudos
3 Replies

Hey hktadepa,

Absolutely VTune works on Banias, has for years now. Something unique to your installation or your sampling experiment is the problem here.

A couple of ideas follow:

1) Try running a simple sampling experiment or two, say, on /bin/ls. Do they work? If so, you don't have a sampling driver or installation problem.

2) If sessions on /bin/ls FAIL, you still have a sampling driver, or installation issue.It probably matters when you made the sampling drivers.If you made them BEFORE you upgraded with the patch, you should remake them now and compare.

3) If the simple experiments PASS *and* you made the drivers with the VDK after you upgraded, then my gut here is you're not seeing a Banias issue, but a kernel driver issue, and the act of sampling the driver is disrupting the kernel itself, causing it to panic.

A few simple binary experiements will tell us a lot (/bin/ls, super easy). Report back here what you see, and let us know.

If this advice is absolutely useless to you, you should open a Premier case on this immediately.



0 Kudos
This is a test reply.

Message Edited by cmty_user2 on 05-04-2004 10:14 AM

0 Kudos

This is a multiline test reply.

Line 2.

Looks double spaced to me.

0 Kudos