Community
cancel
Showing results for 
Search instead for 
Did you mean: 
YWang84
Beginner
204 Views

VTune installation on MacOS

I met two issues when installing VTune in my Macbook whose version is 10.11.6.

The first one is I tried to install "vtune_amplifier_2019_update4.dmg" but there is nothing shown up after double clicking the .app file.

The second issue is that I then switched to install "vtune_amplifier_2019.dmg", the installation panel can show up, but it require the license. I have the serial number, so I input my mac address and host name to activate and generate the license file. Then I downloaded the license file to my local dir. Afterwards I continue the installation by inputting the license file path but unfortunately the installer said "the license file(s) you provided is not valid for this product."

What's wrong? Why can't I use the license? Is it a must to setup a license server?

0 Kudos
11 Replies
204 Views

Hi Yujia,

Let's try fixing 2019 Update 4 first. Run VTune from a terminal:

/Applications/Intel\ VTune\ Amplifier\ 2019.app/Contents/MacOS/amplxe-gui

Add see if any errors are reported to the console.

-Stas

YWang84
Beginner
204 Views

Here is the file list under MacOS, there is no amplxe-gui.

install.sh

libISSASoapMessenger.dylib

liblzma.dylib

silent.cfg

install_gui

libarchive.13.dylib

libssl.1.1.dylib

sv.dylib

libISSASecureWebChannel.dylib

libcrypto.1.1.dylib

qt

uninstall.sh

204 Views

Hi Yujia,

I assumed that you did install VTune 2019 Update 4 and the issue was running VTune. But looks like the issue is with the installer itself. When you run it - nothing happens. Please confirm.

-Stas

204 Views

Hi Yujia,

VTune 2019 Update 4 installer supports MacOS 10.13+ hence the issue running it on 10.11.

So you could either try Update 4 on a MacOS 10.13+ or address the license issue for the original 2019 release.

For the license issue, please double check if your license is still valid and not expired.

-Stas

YWang84
Beginner
204 Views

Hi Stas, it makes sense that Update 4 installer cannot be launched.

For license issue, I am sure the license should work as we just purchase the license a few weeks ago. I got the serial number first, and then login with my email account, register the serial number, activate it by clicking the serial number and input my Mac address and host name. I don't know what exactly I should troubleshoot this, is there any steps I missed or doing wrong? 

204 Views

Also, please elaborate on your steps to provide the license.

If you have a serial number you could just enter it, you do not need to generate or download a license file manually.

And you mentioned entering mac address and hostname. These are needed for acquiring floating license from a license server. You probably have a single user license, so license service is not something you need.

YWang84
Beginner
204 Views

My license is floating license type even though I have one of serial numbers. If I input the serial number directly in the installation process, I will get this error. (please look at my new attachment)

Maybe it is because I have to setup a license server somewhere first?

204 Views

Hi Yujia,

We'd need some confidential info from you like license serial number, etc. Thus please submit a service request at https://software.intel.com/en-us/support/priority-support. 

Attach additional information to your request. Set the following environment variables in a terminal:

LM_LICENSE_FILE=/Users/Shared/Library/Application Support/Intel/Licenses 
INTEL_LM_DEBUG=3
INTEL_LMD_DEBUG=%TEMP%/licensecheckout.log

Then run installer from the same terminal session and copy licensecheckout.log. It's a text file that will contain license serial number and some personal info like machine name, etc. You could review it and remove data that you do not want to share. Then attach the file to the service request.

Sorry for the inconvenience.

Regards,
Stas

YWang84
Beginner
204 Views

Hi Stas, I see this in the page you shared to me.

If your company has a floating license, make sure to add each user before they submit a support request.

I don't know if I should submit a SR without knowing whether all users are added or not. We got floating licenses weeks ago and would like to share it in the team, probably I am the first user to use on VTune, does it suppose to submit an SR by me or some other role like the ops guy who request the license at first?

204 Views

Yujia,

Please contact the ops person/team who set the license server in your org. They could either already know the solution to your issue or would know how to escalate the issue to Intel.

-Stas

YWang84
Beginner
204 Views

It sounds good to me. Thank you Stas!

Reply