Analyzers
Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4963 Discussions

VTune timeline report: Unknown error has happened in timeline data provider

StephenB-C
Beginner
995 Views

Hi,

tdlr:

I'm not able to generate a VTune  timeline report from the command line

    Unknown error has happened in timeline data provider.
    vtune: Error: 0x40000023 (User input error)

 

details:

See details below on how to replicate.  Can you suggest how to fix this?

 

 

(Intel(R) VTune(TM) Profiler 2023.0.0 (build 624757) Command Line Tool )

 

Using  the matrix example shipped with oneAPI (as in /opt/intel/oneapi/vtune/latest/samples/en/C++/matrix)    I get the following:

 

STEP 1: build the application 

         cd  ./matrix/src/

         make 

STEP2: profile hotspot

    cd ../        

    vtune -collect hotspots ./matrix

 

STEP 3:  generate a summary  report [WORKS OK]

      vtune -report summary -r r000hs/

  

STEP 4: generate a timeline report [FAILS]

    vtune -report timeline -report-knob column-by="Thread" -r r000hs/
    vtune: Using result path `/home/stephen/dv/VTUNE-HTML/matrix/r000hs'
    vtune: Executing actions 0 %
    vtune: Executing actions 0 % Finalizing results 
    vtune: Executing actions 50 % Finalizing results
    vtune: Executing actions 50 % Generating a report
    vtune: Executing actions 50 % Setting data model parameter
    vtune: Executing actions 75 % Setting data model parameter
    vtune: Executing actions 75 % Generating a report

    Unknown error has happened in timeline data provider.
    vtune: Executing actions 100 % Generating a report
    vtune: Executing actions 100 % done

    vtune: Error: 0x40000023 (User input error)

 

0 Kudos
5 Replies
StephenB-C
Beginner
985 Views

one small typo in how to replicate the error. the matrix app should be built in the linux folder 

0 Kudos
RemyaP_Intel
Moderator
900 Views

Hi,


Thanks you for posting in Intel Communities.


We are working on this internally. We will get back to you soon with an update. Meanwhile, could you also please share the OS and Hardware details.


Regards,

Remya Premdas


0 Kudos
Jeffrey_R_Intel1
Employee
864 Views

Try : vtune -report timeline  -report-knob=CPUTime  -r r000hs/
or: vtune -report timeline  -report-knob=CPUTime -report-knob group-by=Thread -r r000hs/
or: vtune -report timeline  -report-knob=CPUTime -report-knob group-by=Thread -report-knob sort-column-by=PMUEventCount -r r000hs/

 

Note no space in "CPUTime"

0 Kudos
RemyaP_Intel
Moderator
791 Views

Hi,


We haven't received any update from you. Is your issue resolved?


Thanks,

Remya Premdas


0 Kudos
RemyaP_Intel
Moderator
709 Views

Hi,


We assume that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Remya Premdas


0 Kudos
Reply