Community
cancel
Showing results for 
Search instead for 
Did you mean: 
bmchenry
New Contributor II
106 Views

Vtune 9.0.10.454 installation pop up infinite loop

Downloaded Vtune 9.0.10.454 to install for 30 day trial.

Received serial number.

Install appeared to be working correctly then during the 'final?' phase the 'starting installation' dialog starts popping up, clearing, pops up, clears, pops up, clears....

no rhyme or reason. only way to stop is to cancel the install

Reboot. Tried again, same problem.

There doesn't seem to be any log file written which might let me know why this is happening.

This machine has no problems whatsoever with installation, etc.

I was surprised not to see any others having this problem.

any ideas?

0 Kudos
5 Replies
Andrey_Pavlenko
Beginner
106 Views

Hi,

I could try to help you, but I need more related info:

  • did you use thew_vt_p_9.0.016.exe package or an older one?
  • what's your OS (and SP) and CPU arch?
  • did you have some older VTune version installed in this system before?
  • how long did you wait for pop-up message boxes series to complete? don't you think they will finish after 20-30 pop-ups?

Besides, open the folder specified in the TEMP env. variable (e.g. by "cd %TEMP%" command in the cmd.exe session) and check if you have the "vtinstlog.txt" file there. If you have this file I will be able to say more looking into.

/Andy.

bmchenry
New Contributor II
106 Views

Hello. Thanks for the response. Sorry for incomplete nature of the message, wanted to see if others experienced the same problem.

1) used 9.0.016.exe.Package ID: w_vt_pu_9.0.016. Package Contents: "VTune 9.0 Update 3 for Windows" Build Number: 454 Build ID: 2007.06.28 18:20:33

2) XP Pro, v 2002, SP 2, Thinkpad z60m, 2 GHz, 1.5 GB RAM, 100 gb disk, etc

3) No other version of Vtune installed

4) after 10 minutes, it kept popping and popping and finally had to kill it all.

initialsearch found no file vtinstlog.txton the system. But manually went to temp directory & found.

log starts 16:21:47:640, kill message rcd at 16:30:21

log file 3 megs in size. shall I send via email or ftp?

snippets of 1st part and last part of log file below.

Is the popup of the installation dialog expected behavior as it registers various modules?

I saw it as an 'infinite loopproblem' and as you see after 9 minutes or I killed it.

should I try again (and allow it to run for 15 min?? or how long?)

Thnaks for the assistance.

brian

=== Verbose logging started: 7/23/2007 16:21:47 Build type: SHIP UNICODE 3.01.4000.4039 Calling process: C:WINDOWSsystem32MSIEXEC.EXE ===
MSI (c) (88:38) [16:21:47:640]: Resetting cached policy values
MSI (c) (88:38) [16:21:47:640]: Machine policy value 'Debug' is 0
MSI (c) (88:38) [16:21:47:640]: ******* RunEngine:
******* Product: C:Program FilesIntelDownloadw_vt_p_9.0.016Setup32VTune.msi
******* Action:
******* CommandLine: **********
MSI (c) (88:38) [16:21:47:640]: Machine policy value 'DisableUserInstalls' is 0
MSI (c) (88:38) [16:21:48:031]: SOFTWARE RESTRICTION POLICY: Verifying package --> 'C:Program FilesIntelDownloadw_vt_p_9.0.016Setup32VTune.msi' against software restriction policy
MSI (c) (88:38) [16:21:48:031]: SOFTWARE RESTRICTION POLICY: C:Program FilesIntelDownloadw_vt_p_9.0.016Setup32VTune.msi has a digital signature
MSI (c) (88:38) [16:21:49:000]: SOFTWARE RESTRICTION POLICY: C:Program FilesIntelDownloadw_vt_p_9.0.016Setup32VTune.msi is permitted to run at the 'unrestricted' authorization level.
MSI (c) (88:38) [16:21:49:281]: Cloaking enabled.
MSI (c) (88:38) [16:21:49:281]: Attempting to enable all disabled priveleges before calling Install on Server
MSI (c) (88:38) [16:21:49:296]: End dialog not enabled
MSI (c) (88:38) [16:21:49:296]: Original package ==> C:Program FilesIntelDownloadw_vt_p_9.0.016Setup32VTune.msi
MSI (c) (88:38) [16:21:49:296]: Package we're running from ==> C:DOCUME~1BRIANM~1LOCALS~1Temp102d1a9e.msi
MSI (c) (88:38) [16:21:49:343]: APPCOMPAT: looking for appcompat database entry with ProductCode '{3BEADE1E-7521-4306-93CF-B52A75061C46}'.
MSI (c) (88:38) [16:21:49:343]: APPCOMPAT: no matching ProductCode found in database.
MSI (c) (88:38) [16:21:49:343]: MSCOREE not loaded loading copy from system32
MSI (c) (88:38) [16:21:49:421]: Machine policy value 'TransformsSecure' is 0
MSI (c) (88:38) [16:21:49:421]: User policy value 'TransformsAtSource' is 0
MSI (c) (88:38) [16:21:49:437]: Machine policy value 'DisablePatch' is 0
MSI (c) (88:38) [16:21:49: 437]: Machine policy value 'AllowLockdownPatch' is 0
MSI (c) (88:38) [16:21:49:437]: Machine policy value 'DisableLUAPatching' is 0
MSI (c) (88:38) [16:21:49:437]: Machine policy value 'DisableFlyWeightPatching' is 0
MSI (c) (88:38) [16:21:49:437]: APPCOMPAT: looking for appcompat database entry with ProductCode '{3BEADE1E-7521-4306-93CF-B52A75061C46}'.
MSI (c) (88:38) [16:21:49:437]: APPCOMPAT: no matching ProductCode found in database.
MSI (c) (88:38) [16:21:49:437]: Transforms are not secure.
MSI (c) (88:38) [16:21:49:437]: Command Line: SETUPEXEDIR=C:Program FilesIntelDownloadw_vt_p_9.0.016Setup32 CURRENTDIRECTORY=C:Program FilesIntelDownloadw_vt_p_9.0.016Setup32 CLIENTUILEVEL=0 CLIENTPROCESSID=5256
MSI (c) (88:38) [16:21:49:437]: PROPERTY CHANGE: Adding PackageCode property. Its value is '{3E38ECBB-4B1A-4608-B641-154EC806262F}'.
MSI (c) (88:38) [16:21:49:437]: Product Code passed to Engine.Initialize: ''
MSI (c) (88:38) [16:21:49:437]: Product Code from property table before transforms: '{3BEADE1E-7521-4306-93CF-B52A75061C46}'
MSI (c) (88:38) [16:21:49:437]: Product Code from property table after transforms: '{3BEADE1E-7521-4306-93CF-B52A75061C46}'
MSI (c) (88:38) [16:21:49:437]: Product not registered: beginning first-time install
MSI (c) (88:38) [16:21:49:437]: PROPERTY CHANGE: Adding ProductState property. Its value is '-1'.
MSI (c) (88:38) [16:21:49:437]: Entering CMsiConfigurationManager::SetLastUsedSource.
(snip)

at tail end

Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBindbgexectrl.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBindbgexectrlps.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBindbgexectrlps.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinfilecopier.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBinfilecopier.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinfilecopier.exe
Registration: Command line: "C:Program FilesIntelVTuneSharedBinfilecopier.exe" /RegServer
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinfilecopierps.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBinfilecopierps.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinfiledialog.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBinfiledialog.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinfiledialogps.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBinfiledialogps.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinFileMgr.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBinFileMgr.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBininstsupp.exe
Registration: Co mmand line: "C:Program FilesIntelVTuneSharedBininstsupp.exe" /RegServer
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinNoteSupp.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBinNoteSupp.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinProductInfo.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBinProductInfo.dll"
Register32.BEED0BAD_EF12_430E_A08A_5ED9BAC1A1F5: File: C:Program FilesIntelVTuneSharedBinpropbag.dll
Registration: Command line: "C:WINDOWSsystem32 egsvr32.exe" /s "C:Program FilesIntelVTuneSharedBinpropbag.dll"
Action 16:30:18: CancelSetup. Dialog created
Action ended 16:30:21: InstallFinalize. Return value 2.
Action 16:30:21: Rollback. Rolling back action:
Rollback: Registering modules
Rollback: Unregistering modules
(snip)

Brian

Andrey_Pavlenko
Beginner
106 Views

Hi Brian.

Due to

some reason I didn't get notification regarding new message in this thread.

As for the problem with VTune install on your system - the popups may appear after VTune install is completed when installing other products due to VTune installation issue. But I never observed popups during VTune installation and besides they never were infinite - just 20-30 popup series.

Anyway, please send me you install log file (ZIP it, of course) to Andrey.Pavlenko@intel.com

Besides, please look if you have "C:Program FilesIntelVTune" folder in your system (or the other one if you tried to install VTune to non-default location). If yes, create the "CompAnchor.txt" file with any content there. Then try to run VTune install again.

/Andy.

bmchenry
New Contributor II
106 Views

Andy,

Thanks for the response and sorry for the delay in my response (when it rains, it floods! work always comes to me in the form of storms!)

I restarted the installation but allowed the 'infinite' loops to run (since one in this thread suggested that it was 'by design') and they finally subsided and the Vtune software is now installed on the system.

There must have been >100 of those 'beginning Installation' popups which when I first installed I saw as a problem with the installation but apparently is 'by design'?

Perhaps a better message like 'registering components' or whatever it is doing during the hundreds of popups would alleviate the anxiety at seeing multiple 'beginning installation' message boxes?

Thanks again

brian

David_A_Intel1
Employee
106 Views

Just for the benefit of others, since Brian's problem has been resolved, I wanted to pass on this info:

The install engineer has identified a workaround: To stop the Windows* Installer from continuously repairing the VTune analyzer installation at reboot or DLLs registration, create a text file called "CompAnchor.txt" with any content in the VTune analyzer product folder (typically "C:Program FilesIntelVTune").

This is certainly not "by design" and we hope to fixthe problemin a future release.

Reply