Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AndrewC
New Contributor I
88 Views

Windows XE 2015:"Accurate CPU time detection was disabled. Trace session is already in use"

I am using Amplifier XE 2015 on Windows 7 and trying to profile 4xMPI processes running on my local machine. I get 3x of the above messages when running 4 MPI processes. Is that expected? That is it seems that XE is having problems profiling multiple MPI processes at the same time.

mpiexec -n 4 amplxe-cl -result-dir my_result_ah -collect hotspots -- <my_exe.exe>

0 Kudos
10 Replies
Peter_W_Intel
Employee
88 Views

"Accurate CPU time is disabled..." - this warning message hints that you might use CLI in cmd, which is under administrator privilege.

Peter_W_Intel
Employee
88 Views

I haven't experienced message of "...Trace session is already in use" - was it due to some VTune processes remained?

You may try -

amplxe-cl -result-dir my_result_ah -collect hotspots -- mpiexec -n 4 <my_exe.exe> ; which combined performance data from four processes in one result.

Peter_W_Intel
Employee
88 Views

amplxe-cl -result-dir my_result_ah -collect hotspots -- mpiexec -n 4 <my_exe.exe> ; which combined performance data from four processes in one result.

Above measures performance data of MPI processes which work on single node, in order to measure MPI processes work on multiple nodes, try:

mpirun -gtool "amplxe-cl -r result_dir -collect hotspots:all=node-wide" -n 4 <my_exe.exe>

Check if previous VTune process is remained in system:  "ps -ae | grep amplxe-cl" , kill it if any. 

 

AndrewC
New Contributor I
88 Views

Thanks for the responses.

I have full administrator privileges on this machine. Note this is on Windows 7. No other instances of ampl are running. I have rebooted   to make sure.

I think the interesting information is that I get 3 warnings when profiling 4 MPI processes. Anyway, it seems to be harmless as after starting from scratch after a reboot, although I still get the warning messages, the profile results are all good and complete for all 4 processes.
 

Peter_W_Intel
Employee
88 Views

This is a good news that you can get normal VTune's result(s). It seemed that VTune worked on one rank and detected there were performance data collections on other ranks. Yes, it is harmless warning message...

Vitaly_S_Intel
Employee
88 Views

"Accurate CPU time detection" allows to improve the precision of times for active CPU intervals. The collection technology it uses cannot be started twice on a system.

Running

mpiexec -n 4 amplxe-cl -result-dir my_result_ah -collect hotspots -- <my_exe.exe>

you're starting 4 amplxe-cl collections on the system causing this warning to appear. You may simply ignore these warnings actually.

Another way is to try command lines Peter suggested:

amplxe-cl -result-dir my_result_ah -collect hotspots -- mpiexec -n 4 <my_exe.exe>

or

mpirun -gtool "amplxe-cl -r result_dir -collect hotspots:all=node-wide" -n 4 <my_exe.exe><

which will start just one collection session on a system.

Dmitry_P_Intel1
Employee
88 Views

Please note that -gtool option that Peter mentioned enabled only in Intel MPI starting from Intel Paralell Studio XE 2016 Beta (5.1.0) and only for Linux.

Thansk & Regards, Dmitry

Peter_W_Intel
Employee
88 Views

Please note that -gtool option that Peter mentioned enabled only in Intel MPI starting from Intel Paralell Studio XE 2016 Beta (5.1.0) and only for Linux.

Hi Dmitry,

I found that I also can use -gtool option in VTune Amplifier XE 2015 U3. You're right - I used IMPI 5.03 on Linux, Cluster system.

AndrewC
New Contributor I
88 Views

Thanks for all the suggestions! Amplifier XE 2015 works extremely well on both Windows and Linux for me.

Every release has been more robust, faster and with more useful features!

Vitaly_S_Intel
Employee
88 Views

Than you vasci_ for the feedback! We're pleased to hear that!

Reply