Community
cancel
Showing results for 
Search instead for 
Did you mean: 
YJing8
Novice
402 Views

Now I am familier with PAC software and have a question

0 Kudos
10 Replies
63 Views

hi,

 

What is the question?

YJing8
Novice
63 Views

 

question:  When I am installing the openvino  for PAC(of Arria 10), there is no such selection. Then I selected (2), but  there are many warning and error

 

 

montage-Purley# ./install_openvino_fpga_dependencies.sh

Getting OpenVINO Information

Would you like to setup an FPGA? Select an option below.

Select (1) for None, (2) Intel® Arria® 10 GX FPGA Development Kit, (3) for Intel® Vision Accelerator Design with Intel® Arria® 10 FPGA (IEI Mustang-F100-A10):

1) none

2) Intel® Arria® 10 GX FPGA Development Kit

3) Intel® Vision Accelerator Design with Intel® Arria® 10 FPGA (IEI Mustang-F100-A10) 

#? 2

Selected: Intel® Arria® 10 GX FPGA Development Kit

The NEO OpenCL GPU driver is required for using the GPU with OpenVINO. Would you like to install it?

Please select (y/n)

y

Do you want to setup a Movidius Neural Compute Stick?

Please select (y/n)

y

Do you want to setup an Intel® Vision Accelerator Design with Intel® Movidius™ VPUs card?

Please select (y/n)

y

Install NEO OCL

Intel OpenCL graphics driver installer

Looking for previously installed user-mode driver...

dpkg-query: 没有找到与 intel-opencl 相匹配的软件包

dpkg-query: 没有找到与 intel-ocloc 相匹配的软件包

dpkg-query: 没有找到与 intel-gmmlib 相匹配的软件包

Found intel-igc-core installed, uninstalling...

dpkg: 依赖问题阻止了卸载 intel-igc-core 的操作:

 intel-igc-opencl 依赖于 intel-igc-core.

dpkg: 处理软件包 intel-igc-core (--purge)时出错:

 依赖问题 - 不会执行卸载

在处理时有错误发生:

 intel-igc-core

ERROR: unable to remove intel-igc-core

      please resolve it manually and try to launch the script again.

正在读取软件包列表... 完成

正在分析软件包的依赖关系树      

正在读取状态信息... 完成      

libjson-c2 已经是最新版 (0.11-4ubuntu2)。

libusb-1.0-0 已经是最新版 (2:1.0.20-1)。

libboost-filesystem1.58.0 已经是最新版 (1.58.0+dfsg-5ubuntu3.1)。

libboost-program-options1.58.0 已经是最新版 (1.58.0+dfsg-5ubuntu3.1)。

libboost-thread1.58.0 已经是最新版 (1.58.0+dfsg-5ubuntu3.1)。

libssl1.0.0 已经是最新版 (1.0.2g-1ubuntu4.15)。

libudev1 已经是最新版 (229-4ubuntu21.22)。

升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 151 个软件包未被升级。

./install_openvino_fpga_dependencies.sh: line 371: /deployment_tools/inference_engine/external/hddl/generate_udev_rules.sh: No such file or directory

sed: can't read /etc/udev/rules.d/98-hddlbsl.rules: No such file or directory

[Error] Can't find path to HDDL-R drivers. Skipping HDDL-R setup.

正在读取软件包列表... 完成

正在分析软件包的依赖关系树      

正在读取状态信息... 完成      

libelf-dev 已经是最新版 (0.165-3ubuntu1.2)。

升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 151 个软件包未被升级。

[Error] Quartus not find. If it's installed, try 'sudo updatedb' and re-run this script. Otherwise install Quartus and re-run.

[Info] Warning: multipe multiple Quartus instances found!

Size of array: 0

Installing aocl flash fix to: /linux64

[Error] If you want to use the aocl flash utility: install Quartus and run this script again.

Cannot find board_env.xml in /opt/altera/aocl-pro-rte/aclrte-linux64/board/a10_1150_sg1

 

HRZ
Valued Contributor II
63 Views

>ERROR: unable to remove intel-igc-core

 

Removing that package requires root permissions which is likely why the script is failing to uninstall it. Either remove that package manually, or run the script as root/with sudo.

YJing8
Novice
63 Views

​Whether is the selection of 2 ( Intel® Arria® 10 GX FPGA Development Kit)    is correct?

 

YJing8
Novice
63 Views

​As my board is PAC board, not Development Kit, but there is no such selection

63 Views

Hi,

 

For Arria 10 PAC kindly refer to this installation guide:

http://docs.openvinotoolkit.org/2019_R1.1/_docs_install_guides_PAC_Configure_2019R1.html

 

Let me know if the errors still persist.

 

Regards.

Shawn_S_Intel
Employee
63 Views

The  ./install_openvino_fpga_dependencies.sh script that you reference is from fpga_support_files.tgz and is NOT applicable to the PAC. This is not clear in the documentation. We will get this addressed.

 

You can safely ignore the fpga_support_files instructions when using the Arria 10 PAC.

63 Views

Hi,

 

Are you still facing the installation issue?

 

YJing8
Novice
63 Views

Sometime it is ok, sometim not. Not stable.

Also the manual is too seperated and some tcl script has mistake. I change it by myself.

http://docs.openvinotoolkit.org/2019_R1.1/_docs_install_guides_installing_openvino_linux_fpga.html#i...

63 Views

Hi,

 

May I know which steps has mistakes?