Application Acceleration With FPGAs
Programmable Acceleration Cards (PACs), DCP, DLA, Software Stack, and Reference Designs
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
436 Discussions

OpenCL 18.1 Command Queue does not flush/finish/update.

rheine
Beginner
690 Views

We upgraded our tools to from 15.0 to 18.1. Previously working opencl code now does not work. Command Queues never flush or complete. Underneath we can see that the FPGA kernels do start and run one time, but then the queue is blocked in a unflushed state.

A simple solution would be to find the quartus 15.0 tools again. Is that possible?

0 Kudos
7 Replies
aikeu
Employee
670 Views

Hi rheine,

 

Sorry to inform that I am not able to find back the 15.0 tools from years ago.

Recommendation will be using to latest quartus version.

 

Thanks.

Regards,

Aik Eu

rheine
Beginner
664 Views

As the best as we can tell, the latest tools are fundamentally broken and do not allow us to run opencl on the Cyclone 5 SOC ARM.  We are at a critical impasse due to the lack of original parts from Intel.

Updating tools has been attempted and do not work.  There must be an archive somewhere to maintain full support for Intel products.

aikeu
Employee
655 Views

Hi rheine,


I am trying to further query on your request.

Will let you know when I have any new info.


Thanks.

Regards,

Aik Eu


aikeu
Employee
640 Views

Hi rheine,

 

I have help to ask again and I am getting the same respond where customer is recommeded to upgrade the quartus to latest version.

Quartus 15.0 is not supported and officially not available to be downloaded.

The archive version is not an official version and is not recommended to provide to customer. There might be issues which we are not able to further support.

If you have upgraded to the latest Quartus and face any issues, we can support on the issues with more details provided.

 

Thanks.

Regards,

Aik Eu

rheine
Beginner
631 Views

We have attempted every tool from 17 to 19. None of them work as per the original 15. There seems to be something fundamentally broken in the openCL libraries as the command queues never flush or complete. This does not occur with our original v15 built tools. Due to Intel not providing the chips we need, we no longer have time to deal with a long winded minimal support solution. I will need real support for this, not hope that someone will get back to me on a forum.

aikeu
Employee
600 Views

Hi rheine,


Sorry for the inconvenience.

I found out that you can actually try to contact sale representative to query on this particular matter.

If you get your product from a distributor, you may reach them from the link below:

https://marketplace.intel.com/s/pmp-partner-program/a723b0000008PICAA2/distributor


Thanks.

Regards,

Aik Eu


aikeu
Employee
579 Views

Hi rheine,


I do not have further suggestion as compared to the information provided on the other thread.

I will close this thread for now.


Thanks.

Regards,

Aik Eu


Reply