Application Acceleration With FPGAs
Programmable Acceleration Cards (PACs), DCP, DLA, Software Stack, and Reference Designs
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
424 Discussions

Synthesis not working after update to OPAE 1.3

AIvan11
Novice
695 Views
Info (16678): Successfully loaded final database: elapsed time is 00:00:17 Info (18936): Using revision output_files/dcp.green_region.pmsf as a baseline for afu_fit.green_region mask verification Internal Error: Sub-system: PGMIO, File: /quartus/h/pgmio_pof2_sys.h, Line: 194 ERROR IN READING unknown_tag 64 Stack Trace:   0x4db669: POF_READER::parse(FIO_PATH const&, char const*) + 0x509 (pgm_pgmio) 0x4db8db: PGMIO_POF2_PARSER::read_raw_sof(FIO_PATH const&, PGMIO_IPOF2_LISTENER&, char const*) + 0x18b (pgm_pgmio) 0x4dbbc5: PGMIO_POF2_IO::read_pmsf(FIO_PATH const&, PGMIO_IPOF2_METADATA&, PGMIO_IPOF2_DATA&, PGMIO_IPOF2_MASK&, PGMIO_IPOF2_LEGACY*) + 0x85 (pgm_pgmio) 0x62517: ASM2_PR_REGION::read_pmsf(ASM2_ITYPE_DEVICE&, FIO_PATH const&) + 0x7d (comp_asm2) 0x6fc1f: ASM2_PR_MASKS_ANALYZER::verify_region_mask(ASM2_IDEVICE&, ASM2_IPR_REGION&, std::string const&, FIO_PATH&) + 0x323 (comp_asm2) 0x700a0: ASM2_PR_MASKS_ANALYZER::verify_regions(ASM2_IDEVICE&, ASM2_IPARTITIONS const&) + 0x23c (comp_asm2) 0x5ef27: ASM2_PR_ASSEMBLE::verify_regions(ASM2_IDEVICE&, ASM2_IPR_PARTITIONS const&, ASM2_IREGIONS_ANALYZER&) + 0x5d (comp_asm2) 0x606b2: ASM2_PR_ASSEMBLE::assemble(DBCM_CHIP const&, DBCM_DEVICE const&, ASM2_IDEVICE&, ASM2_IPARTITIONS const&, ASM2_IBIT_LISTENER::IMASKS*) + 0x262 (comp_asm2) 0x220bc: ASM2_INSTANCE::assemble_to_bits(ASM2_ICHIP&, ASM2_IDEVICE&) + 0x6d0 (comp_asm2) 0x3f20d: ASM2_STATE::device_assemble(int) + 0x8b (comp_asm2) 0x36f8dd: asm_assemble_asmm(CMP_FACADE*, CDB_CHIP_DB_ENTRY*, ASM_OPTIONS*, ASM_PGM_OPTION_DATA*, unsigned int, DEV_FAMILY_ENUM, DEV_FAMILY_ENUM, DEV_PART_MANAGER*) + 0x1780 (comp_asm) 0x29f7d1: asm_assemble(CMP_FACADE*, unsigned int, bool&, FIO_PATH const&) + 0x83b (comp_asm) 0x408c75: QASM_FRAMEWORK::execute() + 0xcd (quartus_asm) 0x1ad86: qexe_standard_main(QEXE_FRAMEWORK*, QEXE_OPTION_DEFINITION const**, int, char const**) + 0x6a7 (comp_qexe) 0x40abf3: qasm_main(int, char const**) + 0xa5 (quartus_asm) 0x3f160: msg_main_thread(void*) + 0x10 (ccl_msg) 0x5b4c: thr_final_wrapper + 0xc (ccl_thr) 0x3f21f: msg_thread_wrapper(void* (*)(void*), void*) + 0x62 (ccl_msg) 0xac5c: mem_thread_wrapper(void* (*)(void*), void*) + 0x5c (ccl_mem) 0x8b49: err_thread_wrapper(void* (*)(void*), void*) + 0x27 (ccl_err) 0x5b8f: thr_thread_wrapper + 0x15 (ccl_thr) 0x41b11: msg_exe_main(int, char const**, int (*)(int, char const**)) + 0xb2 (ccl_msg) 0x40c988: main + 0x26 (quartus_asm) 0x21b97: __libc_start_main + 0xe7 (c)     End-trace

the output of:

quartus_asm --read_settings_files=on --write_settings_files=off dcp -c afu_fit

during the execution of:

$OPAE_PLATFORM_ROOT/bin/run.sh

Everything else succeeds, but somehow assembler fails at the end. Can anyone, please, help me solve this?

 

Thanks.

0 Kudos
1 Solution
AIvan11
Novice
241 Views

Patching Quartus with patch 1.38 that comes with Acceleration Stack 1.2 solved it.

View solution in original post

1 Reply
AIvan11
Novice
242 Views

Patching Quartus with patch 1.38 that comes with Acceleration Stack 1.2 solved it.

Reply