Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ashishkkaul
New Contributor I
96 Views

resume x2goclient session

Hello,

I have not found a way to resume my x2goclient sessions. I also end up having to terminate and start a new one when my connection breaks away. 

I have found that the Terminate button is never enabled in my x2goclient window.

Has someone seen the same issue?

Ashish

0 Kudos
6 Replies
Hazlina_Intel
Moderator
79 Views

Hi @Lawrence_L_Intel @Anil_A_Intel @BoonBengT_Intel @John_T_Intel Have you seen similar issues on the Dev Cloud platform mentioned in this post on the Dev Cloud platform? 

-Hazlina

Lawrence_L_Intel
Employee
75 Views

All terminal and X2go sessions with no keyboard activity seem to terminate in 20-30 minutes. We highly encourage running all the steps in batch mode. regards, Larry

ashishkkaul
New Contributor I
72 Views

Larry,

Can you please elaborate or point me to instructions for running in batch mode? My steps are pretty simple.

  1. devcloud_login
  2. ssh -L "..." from another terminal
  3. Launch X2GOClient

How does batch mode apply to the above?

Lawrence_L_Intel
Employee
68 Views

refer to this document: https://github.com/intel/FPGA-Devcloud/tree/master/main/Devcloud_Access_Instructions#devcloud-access...

and look for the section submitting batch jobs. use this link for access to various quick start guides for the supported workload processing: https://github.com/intel/FPGA-Devcloud/tree/master/main/QuickStartGuides

Find the flow you are working on there is a starting point batch script. Make sure if you are downloading the batch scripts and files to use the "raw" format.

Let me know if this works out ok for you.

 

Thanks

Larry

ashishkkaul
New Contributor I
66 Views

Larry,

I understand that devcloud_login -b will run in batch mode.  Thanks for the pointer.

However, the question in this case is about failing to be able to use the Resume button of the X2GOClient. Let me try running devcloud in batch mode and see if it addresses the issue I am seeing with the X2GOClient.

Ashish

ashishkkaul
New Contributor I
47 Views

Larry,

Running in batch mode does not help solve this problem.

Reply