Community
cancel
Showing results for 
Search instead for 
Did you mean: 
pvangay
Beginner
120 Views

Display Settings Not Persisting with Driver Version 6.14.10.4926 and VBIOS upgrade

Jump to solution
Hi,

Using Driver Version 6.14.10.49.26, we just upgraded to VBIOS 1585, and we just uncovered what we think might be a bug. (Older versions of the VBIOS works fine with this driver - but this new VBIOS does not work well). It turns out that changing the display settings (color depth specificially) does not persist between different users. For instance, if you log in as Administrator, change the colordepth from 32 bit to 16 bit. Log out. Log back in as a different user and these settings will not have changed. This also causes the quick launch icons to be corrupt (display different icons than they are supposed to) - I believe this must be due to the fact that the icon cache is not refreshing (since the color depth change was not detected).

Another interesting thing I found was that if you change the Hardware Acceleration (after playing around, I found that changing it to the two lowest notches works), this problem goes away altogether.

If anyone has any clue why this would be happening - I'd really appreciate it. Here is my System Info in case it'll help.

Intel Graphics Media Accelerator Driver for Mobile Report


Report Date: 05/23/2009
Report Time[hr:mm:ss]: 15:49:35
Driver Version: 6.14.10.4926
Operating System: Windows XP* Professional, Service Pack 2 (5.1.2600)
Default Language: English
DirectX* Version: 9.0
Physical Memory: 3318 MB
Minimum Graphics Memory: 8 MB
Maximum Graphics Memory: 32 MB
Graphics Memory in Use: 7 MB
Processor: x86 family 6 Model 14 Stepping 8
Processor Speed: 1995 MHZ
Vendor ID: 8086
Device ID: 27A2
Device Revision: 03


* Accelerator Information *

Accelerator in Use: Mobile Intel 945 Express Chipset Family
Video BIOS: 1585.0
Current Graphics Mode: 1024 by 768 True Color (60 Hz)



* Devices Connected to the Graphics Accelerator *


Non Active Notebook Displays: 1


* Notebook *

Monitor Name: Plug and Play Monitor
Display Type: Digital
Gamma Value: 1.79
DDC2 Protocol: Supported
Maximum Image Size: Horizontal: Not Available
Vertical: Not Available
Monitor Supported Modes:
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
Display Power Management Support:
Standby Mode: Not Supported
Suspend Mode: Not Supported
Active Off Mode: Supported

* Other names and brands are the property of their respective owners.
0 Kudos
1 Solution
kavnl
Novice
120 Views
4 Replies
jrnaresh
Beginner
120 Views
Quoting - pvangay
Hi,

Using Driver Version 6.14.10.49.26, we just upgraded to VBIOS 1585, and we just uncovered what we think might be a bug. (Older versions of the VBIOS works fine with this driver - but this new VBIOS does not work well). It turns out that changing the display settings (color depth specificially) does not persist between different users. For instance, if you log in as Administrator, change the colordepth from 32 bit to 16 bit. Log out. Log back in as a different user and these settings will not have changed. This also causes the quick launch icons to be corrupt (display different icons than they are supposed to) - I believe this must be due to the fact that the icon cache is not refreshing (since the color depth change was not detected).

Another interesting thing I found was that if you change the Hardware Acceleration (after playing around, I found that changing it to the two lowest notches works), this problem goes away altogether.

If anyone has any clue why this would be happening - I'd really appreciate it. Here is my System Info in case it'll help.

Intel Graphics Media Accelerator Driver for Mobile Report


Report Date: 05/23/2009
Report Time[hr:mm:ss]: 15:49:35
Driver Version: 6.14.10.4926
Operating System: Windows XP* Professional, Service Pack 2 (5.1.2600)
Default Language: English
DirectX* Version: 9.0
Physical Memory: 3318 MB
Minimum Graphics Memory: 8 MB
Maximum Graphics Memory: 32 MB
Graphics Memory in Use: 7 MB
Processor: x86 family 6 Model 14 Stepping 8
Processor Speed: 1995 MHZ
Vendor ID: 8086
Device ID: 27A2
Device Revision: 03


* Accelerator Information *

Accelerator in Use: Mobile Intel 945 Express Chipset Family
Video BIOS: 1585.0
Current Graphics Mode: 1024 by 768 True Color (60 Hz)



* Devices Connected to the Graphics Accelerator *


Non Active Notebook Displays: 1


* Notebook *

Monitor Name: Plug and Play Monitor
Display Type: Digital
Gamma Value: 1.79
DDC2 Protocol: Supported
Maximum Image Size: Horizontal: Not Available
Vertical: Not Available
Monitor Supported Modes:
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
Display Power Management Support:
Standby Mode: Not Supported
Suspend Mode: Not Supported
Active Off Mode: Supported

* Other names and brands are the property of their respective owners.
I think the processor speed cannot cope up with the graphics memory.
Chuck_De_Sylva
Beginner
120 Views
Quoting - pvangay
Hi,

Using Driver Version 6.14.10.49.26, we just upgraded to VBIOS 1585, and we just uncovered what we think might be a bug. (Older versions of the VBIOS works fine with this driver - but this new VBIOS does not work well). It turns out that changing the display settings (color depth specificially) does not persist between different users. For instance, if you log in as Administrator, change the colordepth from 32 bit to 16 bit. Log out. Log back in as a different user and these settings will not have changed. This also causes the quick launch icons to be corrupt (display different icons than they are supposed to) - I believe this must be due to the fact that the icon cache is not refreshing (since the color depth change was not detected).

Another interesting thing I found was that if you change the Hardware Acceleration (after playing around, I found that changing it to the two lowest notches works), this problem goes away altogether.

If anyone has any clue why this would be happening - I'd really appreciate it. Here is my System Info in case it'll help.

Intel Graphics Media Accelerator Driver for Mobile Report


Report Date: 05/23/2009
Report Time[hr:mm:ss]: 15:49:35
Driver Version: 6.14.10.4926
Operating System: Windows XP* Professional, Service Pack 2 (5.1.2600)
Default Language: English
DirectX* Version: 9.0
Physical Memory: 3318 MB
Minimum Graphics Memory: 8 MB
Maximum Graphics Memory: 32 MB
Graphics Memory in Use: 7 MB
Processor: x86 family 6 Model 14 Stepping 8
Processor Speed: 1995 MHZ
Vendor ID: 8086
Device ID: 27A2
Device Revision: 03


* Accelerator Information *

Accelerator in Use: Mobile Intel 945 Express Chipset Family
Video BIOS: 1585.0
Current Graphics Mode: 1024 by 768 True Color (60 Hz)



* Devices Connected to the Graphics Accelerator *


Non Active Notebook Displays: 1


* Notebook *

Monitor Name: Plug and Play Monitor
Display Type: Digital
Gamma Value: 1.79
DDC2 Protocol: Supported
Maximum Image Size: Horizontal: Not Available
Vertical: Not Available
Monitor Supported Modes:
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
1024 by 768 (60 Hz)
Display Power Management Support:
Standby Mode: Not Supported
Suspend Mode: Not Supported
Active Off Mode: Supported

* Other names and brands are the property of their respective owners.

Can you check to make sure that you set Max DVMT in the Bios setting? Typically this isn't set to max when you upgrade.
kavnl
Novice
120 Views

Can you check to make sure that you set Max DVMT in the Bios setting? Typically this isn't set to max when you upgrade.

kavnl
Novice
121 Views
Reply