Community
cancel
Showing results for 
Search instead for 
Did you mean: 
152 Views

Setting gstreamer-vaapi in CentOS 7

Hi,

I am trying to setup gstreamer-vaapi in my intel NUC machine running on CentOS 7.

I have installed the following packages for gst-vaapi:

gstreamer1-vaapi-0.6.1-1.el7.x86_64

gstreamer1-vaapi-devel-0.6.1-1.el7.x86_64

The install is successful.

When I try to do a gst-inspect-1.0 for vaapi plugins, I am getting the following error message:

(gst-plugin-scanner:19432): GStreamer-WARNING **: Failed to load plugin '/usr/lib64/gstreamer-1.0/libgstvaapi.so': /usr/lib64/libgstvaapi-1.4.so.2: symbol vaCreateSurfaces, version VA_API_0.33.0 not defined in file libva.so.1 with link time reference

But the vaapiparse gstreamer plugin is up. There seems to be some problem with  libgstvaapi.so. 

I have installed IMSDK and when I am running simple_session I am getting the VA-API version as 0.35.0

Please let me know how can I proceed further, Any inputs will be greatly appreciated

 

Regards

Thushara

 

0 Kudos
0 Replies
Reply