Ethernet Products
Intel® Ethernet products and technologies
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
3970 Discussions

16.8.1 drivers + 82579V = 0x7F bsod / "The style of the inf is different than what was requested"

Community Manager


I'm getting 0x7F BSODs with the 82579v and the 16.8.1 drivers. Cannot revert to 16.8 or any other lan drivers. Cannot uninstall or reinstall Intel network connections. Can only boot OS with either onboard LAN disabled in BIOS OR intel raid array disks unplugged.

Running Win7 x86 SP1 on an Asus Sabertooth P67, bios version 2103.

Here's what I've tried so far:

1. Everything ran smoothly with the 16.8 drivers, no BSODs or odd behaviour. Then 16.8.1 were released with a specific note about 82579V:

"The version 16.8.1 software package contains a bug fix to the Windows driver for the Intel(R) 82579V Gigabit Network Connection. - If you previously installed version 16.8, and you do not have an Intel(R) 82579V Gigabit Network Connection, then there is no reason to update your software".

Naturally, I upgraded at once, then got a 7F BSOD once the installation process reached the "Registering COM components..." stage.

2. Rebooted and noticed that the driver was indeed updated to 16.8.1 properly, but without the custom intel property pages (the ones with a yellow background). "That's OK", I thought, "The settings are still there, I'll just change them using the advanced property page", only to find out that changing ANY advanced option (checksum offloading, jumbo frame, rss, etc) immediately crashes with a 7F. It happens the second I hit "apply" after changing any such option.

3. Uninstalled the 16.8.1 drivers and tried to reinstall the 16.8 drivers, only to get a 7F bsod on the next reboot.

4. Disconnected USB devices, disabled onboard devices.. eventually found out that I can boot just fine if I disconnect the two sata cables connecting the two HDs that are my raid0 array to the intel sata controller.

5. With the raid array disconnected, tried uninstalling almost all devices in safe mode, installing the latest intel INF (, reinstalling the latest WHQL RST driver ( for the raid controller. No luck. Things seem to get even worse: from this point onward, windows completely refuses to accept *any* 82579V drivers whatsoever, even with the raid array disconnected, complaining that "the style of the inf is different than what was requested".

6. Tried uninstalling intel network connections, only to get this error:

"The installed version of Intel PROSet is not supported for upgrades. You must uninstall it before installing this version".

This is on an uninstall attempt. I get a similar error when I try to install intel network connections from an older/newer driver version.

7. Tried the ghost devices cleanup and manual registry cleanup procedures described here. Double checked each and every key on the list and rebooted. Still cannot uninstall/reinstall intel network connections. Still cannot boot with both intel raid and intel lan enabled.

8. Tried installing all windows updates and again tried to uinstall/reinstall intel network connections and other drivers for the 82579V, including 16.8, 16.8.1 and the ones that came on the motherboard drivers CD. No luck whatsoever.

9. Tried manually installing (through "have disk" etc) the same three driver options. Same BSOD with the raid array plugged in or "the style of the inf is different than what was requested" error with the array plugged out.

I am completely out of ideas. I simply do not understand what the raid driver has to do with the ethernet driver, apart from maybe a terrible device id mismatch somewhere. Why are they affecting each other? They should be completely separate devices, yet their drivers affect each other to the point of zero usability. I am now running with onboard lan disabled, with a silly usb wifi adapter. This post is my hail mary in hope that someone here might think of something new to try.

If anyone has any suggestion, new information, even just a "chin up", I would greatly appreiciate it.



0 Kudos
3 Replies

The last time I had a computer with this many issues, I was able to recover by using one of the Windows restore points. You have made a lot of changes, so I do not know if that will help in this case. If going back in time with Windows works, then this might be your best bet.

As far as a tool that might help you uninstall your old Intel Network Connections software, the support agents for Intel Ethernet adapters have access to the tool. However, I am concerned that something more than the Network Connections software is behind this. Therefore, I would try the Windows system restore to an earlier point in time first. Pick an available time that is before your network updates.

I was thinking that even if the system restore gets you out of the blue screen issues, I would consider backing up your personal files and doing a clean Windows installation. Something very strange seems to be going on here that goes beyond just a network driver update.

I hope this helps. Let us know what works (or does not work.)

Mark H

Community Manager

Dear Mark,

Thanks for your prompt reply and your wise words.

Unfortunately system restore is not an option as I have disabled it a long time ago. I use differential imaging that runs every night instead. Sadly, the external disk that I image to was on loan to my wife's friend during the last two weeks, so the last image that I can restore is over two weeks old. This was obviously Murphy's intention..

Reinstalling the OS or restoring an old image aren't really viable options for me. It would be at least two months until I will be able to afford some downtime for this machine, which is my main editing machine. I will be working hectically towards tight deadlines and it's simply not worth the risk until I am between projects. Other than that, the OS has been installed over three years ago and it has taken me ages to set things up just the way I like them. A reinstall from scratch is an absolute last resort and as much as I'd hate to rely on a USB wireless adapter instead of my trusty Intel ethernet, I would choose the former over a complete reinstall.

I would like to kindly emphasize that there are no other issues with this computer. Apart from the 0x7F BSODs brought forth by the 16.8.1 drivers installation attempt, it is rock solid. There are no problems whatsoever with other drivers or programs, only the Intel ethernet driver / Intel network connections, so I wouldn't classify it as "a computer with this many issues", just a single issue specific to the 16.8.1 drivers and perhaps its COM object(s) registrations. Previous driver updates, from the ones provided with the motherboard to 15.x, to 16.x and finally to 16.8 were simply flawless.

Have you had any similar feedback about the 16.8.1 drivers? any odd behavior or crash reports that can help reproduce and pin down the issue?

Either way, if you can provide me with that cleanup/uninstallation tool for Intel network connections you mentioned, I would very much like to give it a go.

Thank you for your time and patience,



So far your report is all I have seen on a bsod when installing 16.8.1. I don't think the problem was with the 16.8.1 files, but something that happened previously. Otherwise, I think someone else would be reporting the bsod. Of course, yours could just be the first report, but I know that I can install the files on other systems without a bsod.

Whatever the cause, I will contact you privately to figure out what we can do so you don't have to do a clean install. I know from experience how painfully time consuming starting from scratch would be. That really is a last resort.

Mark H