Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
5029 Discussions

82566DM 100MB Auto-Negotiation with 16.4 and 16.5

KTee
New Contributor III
6,806 Views

I recently reloaded an older PC (Intel DQ965GFEKR - 82566DM), and decided to use the 16.5 package upon reinstall. I noticed that network transfers to and from this PC were slower than usual, and I found that it was negotiating at 100Mb/Full Duplex. I tested another PC (Intel DQ67SW - 82579LM) with the same cable/switch etc. and it auto-negotiates at 1Gb/Full-Duplex.

After trying a few things this is what I've found:

- LAN driver packages 16.4 and 16.5 both auto-negotiate at 100mb/Full Duplex since they both use the same driver (e1exxxx.sys 9.14.180.0)

- LAN driver package 16.3 auto-negotiates at 1Gb/Full Duplex (e1exxxx.sys 9.13.41.0)

- The results are the same whether I install the PROSet software or just bare drivers.

- If I force 1Gb / Full Duplex, the network connection disconnects.

- I've tried Windows XP x86 (SP3), Windows XP x64 (SP2), Windows Vista Business x86 (SP1), and Windows 7 Pro x86/x64 (SP1), all with the same

result (16.3 - 1Gb, 16.4/16.5 - 100Mb)

- BIOS version on the DQ965GFEKR is 6100, and I also tried 6077.

- I've tried another PC with the same motherboard (DQ965GFEKR - 82566DM) and it produced the same result as well.

Here are a few screenshots of Win7 Pro x86 with 16.3 and 16.5: http://imgur.com/a/8SzTV http://imgur.com/a/8SzTV

I'm not sure whether other ethernet controllers that use this particular driver are affected. In any case, I'm running with the 16.3 package right now and all is well

Has anybody else noticed this issue with either this or another supported ethernet component supported by this driver?

0 Kudos
24 Replies
idata
Employee
514 Views

I found a copy of the 16.3 driver on http://driverscollection.com/?aid=44317988847f057b9f968ba5ceb MSI (Microstar) Hetis H61 LAN driver v.11.12.36.0 Windows 7 64-bit, Windows 7 archive content

I installed it and it's up at a Gig.

0 Kudos
idata
Employee
644 Views

I'm having this exact same problem as well. The PC is a HP DC7700 Convertible Minitower, the NIC is a "Intel(R) 82566DM Gigabit Network Connection" [sic] according to Windows. Intels automatic driver update utility detects it as "Intel(R) 82566 based Network Controller(OEM)".

During autonegotiation "PROSet" shows 1gbps for a few seconds then drop to 100mbit. If I force 1gbit I get no network connection.

Windows 7 64-bit Ultimate SP1, PROSet 17.1.55.0, driver 9.15.17.0.

The PC is connected to a Linksys E3000 router which also indicates a 100mbit link. Other devices in the network connect to the router at 1gbps without issues. I've used the exact same cables to connect another 1gbit devices as well.

Please let me know if there is anything I can provide to help resolving this issue!

0 Kudos
idata
Employee
644 Views

My college's desktop infrastructure strategy will depend heavily on what happens here. I would like to consider staying with the current strategy of using fat desktop client up to 5-6 years. The college is already influenced by the current trends of migrating to VDI or Ipads and Intel's ability to fix this currently issue will have a major impact on the decision making. Though I have nothing against alternative desktop infrastructures the real ROI doesn't come close to our traditional model for a business of our type and size.

0 Kudos
PGree2
Beginner
514 Views

I am having same problem with 822566mm only auto negotiating at 100MB/s. I have followed the advice here and downed graded driver software and installed the 16.3.48.0 package (driver 9.13.41.0) but there was no difference - still 100MB/s. Does anyone have any ideas.

Have a Toshiba M9 running Windows 7 64-bit.

Thanks

0 Kudos
Reply