Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
3,955 Views

82567LM Gigabit Network Connection Link has been disconnected

I have this error constantly comming up in the event log

Warning 9/30/2009 3:22:09 PM e1yexpress 27 None

Intel(R) 82567LM Gigabit Network Connection Link has been disconnected.

I have a wired connection and I can still surf the Internet, but sometimes the connection slows.

any idea how to fix this?

Tags (1)
0 Kudos
25 Replies
Mark_H_Intel
Employee
696 Views

Are the times of the warning the same time when your laptop might be going into a standby state or shutting down components to save power. If the warnings are being recorded when you are not using the laptop, then you might not need to worry.

When you say the connection slows, do you mean you see the rate of your connection dropping, or do you mean that sometimes getting your data takes longer? If you mean the latter, then the slow down might be caused by something outside of your network. Even if the connection drops while you are active, you probably wouldn't notice a difference in the time it takes to get your data from the Internet.You are probably just seeing the normal Internet slow downs most of us see.

If you think you have a problem on your network you can try a few things that might make a difference.

  1. Make sure you are running the latest driver from your computer manufacturer.
  2. Try a different Ethernet cable.
  3. Make sure that your switch and your network connection are configured for the same speed. Both on auto should work, but you could try forcing both ends to the same speed and duplex settings.
  4. Uncheck any power management tab options in Windows Device Manager that allow Windows to turn of your connection to save power.
  5. Make sure your link partner (your router or switch) has the latest firmware.
  6. Make sure your computer is running the latest BIOS.

Do not be surprised if going through the above steps does not make any difference. The usual cause of slowdowns like you experience on the Internet are caused by something outside of your network and beyond your control.

Mark H

idata
Community Manager
696 Views

It looks like Intel PRO/1000 software (at least 14.6 and 14.7) try to switch to lower speed as part of power saver mode. On most of Cisco switches it causes renegotiation and spanning tree protocol recalculation which causes port unavailability for about 30 seconds. Driver which comes with Windows Server 2008 R2 x64 has an option which disables attempts to save power but it disappears with PROset software installation

idata
Community Manager
696 Views

Changing this "Feature" fixed the issue:

<!--[if gte mso 9]> Normal 0 false false false EN-US X-NONE X-NONE <![endif]--><!--[if gte mso 9]> <w:LsdException Locked="false" Priority="64" SemiHidden="false" ...

idata
Community Manager
696 Views

i can't find that key on my win7 x64. yet the error come up regulary.

can you provide the exact location of this key?

Mark_H_Intel
Employee
696 Views

You do not have to use the registry editor. You can configure the SipsEnabled setting using the System Idle Power Saver(SIPS) in the Advanced tab in the device properties in Windows Device manager. If you have Intel(R) PROSet installed, then look in the Power Management tab for Reduce link speed during system idle. The screen shots below show SIPS locations for both cases. If you do not have a SIPS configuration option, then the driver for that network connection does not support SIPS in that operating system (or maybe you need to update the driver.)

Above shows SIPS property when only the base driver is installed.

Below shows SIPS property when Intel(R) PROSet for Windows Device Manager is installed.

idata
Community Manager
696 Views

Thanks for the tip. Works well when the user is allready using the system. But when you SYSPREP a system it removes that setting, the default setting is set back it sipsenabled=0 which is power save mode . So you need to load a reg file on first log on or in setup.cmd to change this to 1.

Intel should change the default to power save off.

idata
Community Manager
696 Views

14.7 version of the software doesn't have that option. So where's the reg key?

Mark_H_Intel
Employee
696 Views

The driver files I have checked so far (at least in the newest versions) do indeed have SipsEnabled set to "0" by default. However, "0" is the setting for Disabled. Are you experiencing the opposite? What is your driver version and OS?

idata
Community Manager
696 Views

win7 x64 ultimate. driver version 11.2.19.0

Mark_H_Intel
Employee
696 Views

morbidz,

I am guessing that you have a Intel(R) 82567LM-3 Gigabit Network Connection, right? That is different than the Intel(R) 82567LM Gigabit Network Connection. There is no SipsEnabled option for that connection in Windows 7 for Intel(R) 82567LM-3 Gigabit Network Connection.

Some network connections support System Idle Power Saver and some do not. The setting only appears for network connection and OS combinations that have support for the option. Any network connection or adapter that does not show the setting does not have support for the option or does not have support for the option in that OS.

idata
Community Manager
696 Views

i'm not really concerned about having that option i'm concerned about my card dropping the link very frequently.

it's not my wiring as i have the same machine @ work and @ home. same behaviour on both.

idata
Community Manager
696 Views

Again, installing PROSet 14.7 onto DQ45CB with 82567LM-3 causes network connection issues. Microsoft's driver 10.5.1.0 dated 21.10.2008 does not. All PROSets starting from 14.3 have same behavior on Windows Server 2008 R2 (tried up to 14.5 on RC and 14.6 and 14.7 on RTM)

idata
Community Manager
696 Views

thank you, Max! went back to v10.5.1.0 and errors stopped and more importantly media streaming to WDTV(Live) is back to normal!

idata
Community Manager
696 Views

I can confirm this issue (I'm using DQ45EK). After a while, 82567LM-3 drops to 10mbps, and even manually setting it to higher, the link is limited to 10 mbps. After reboot it works again with correct speed.

With Microsoft's driver it works as it should, but otherwise I'd rather use PROSet - Intel or anyone, are <14.3 PROSets stable enough or is the Microsoft's driver the recommended one?

idata
Community Manager
696 Views

I can add the following work around to that:

The SIPS feature is activated once the link is idle and the OS puts the monitor in standby. We had issues with our clients connecting through a 82567LM-3 NIC to our folder redirected data. When de desktop data is redirected to SAN, de data (icons) disappeared from the desktop when de link is disconnected by the SIPS feature (when pressing F5 on desktop the icons directly re-appear). Since the latest drivers don't provide configuring SIPS through driver settings we disabled the monitor standby through GPO as a workaround.

Since HP is our hardware supplier I opened a case with them and reported this issue with the request of supplying a configuration method for us to manage SIPS (and other power saving related features not controlled by OS power management). If interested i can keep you guys posted on any progress coming from that case/request.

idata
Community Manager
696 Views

Hi Snee,

I'm having a very similar issue, particularly with the HP EliteBook.

Therefore I would be very interested to see what you've had back from HP and grateful if it leads to a resolution to the problems I'm seeing.

Thanks.

idata
Community Manager
696 Views

Check all the cable connected to router and repair your connection.

idata
Community Manager
696 Views

I'm having the same trouble on a Dell Optiplex 760 with Windows7 x64

I've disabled all the power saving settings I could find both within Windows and the BIOS (& even tried disabling MEBx incase it interfered) but no joy.

It occurs for me when the machine's screen is locked (first giveaway was outlook 2007 nagging for passwords when unlocking the screen) but doesn't seem related to inactivity as it even disconnected the link whilst I was using the machine remotely over RDP from a terminal.

My link is connected to an Avaya 1608 IP phone which seems unaffected when the PC link disconnects.

idata
Community Manager
696 Views

i have the same machine with the same OS. Going back to MS driver fixed the issue, but here's some interesting info.

The problems with dropped connections were happening while i was connected to a 10/100 router, i've since upgraded to a gigabit switch and decided to try the new driver. So far it's been a week w/o any problems. Looks like the problem with intel driver was correctly negotiating with a 10/100 router

idata
Community Manager
283 Views

@morbidz - do you know what the brand and model number of the 10/100 router was showing the problem? Your post helps out a lot. Also are you now using the latest driver for your LAN connection or are you on an older version that came from Microsoft? If you are using the Microsoft version, have you tired out the latest release from Intel?

Thank you for using Intel(R) Ethernet.

Reply