Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
2,172 Views

82576 Gigabit Ethernet: Enabling MPE bit causes Unknown Unicast to accept

Hi,

We are using 82576 Gigabit Ethernet Controller, as per the document (8.10.1 Receive Control Register - RCTL (0x00100; R/W)

, page No. 515) attached and also the ethtool output,

- Even if the UPE (Unicast Promiscuous Enable) bit is reset (disabled) we still seem to receive any Unknown Unicast Packets.

- If we disable the MPE (Multicast Promiscuous Enable) bit then we stop receiving any Unknown Unicast Packets.

While I do not see any reason why any one would disable UPE and enable MPE, just wanted to know if it is expected behavior.

Our assumption was that if the UPE bit is disabled then we should NOT receive any Unknown Unicast (assume we do not have any

RAL entries for MAC filtering)

Linux# ethtool -d eth1

0x00000: CTRL (Device control register) 0x40D00240

Invert Loss-Of-Signal: no

Receive flow control: disabled

Transmit flow control: disabled

VLAN mode: enabled

Set link up: 1

D3COLD WakeUp capability advertisement: enabled

Auto speed detect: disabled

Speed select: 1000Mb/s

Force speed: no

Force duplex: no

0x00008: STATUS (Device status register) 0x00080383

Duplex: full

Link up: link config

Transmission: on

DMA clock gating: disabled

TBI mode: disabled

Link speed: 1000Mb/s

Bus type: PCI Express

0x00100: RCTL (Receive control register) 0x0400803A

Receiver: enabled

Store bad packets: disabled

Unicast promiscuous: disabled

Multicast promiscuous: enabled

Long packet: enabled

Descriptor minimum threshold size: 1/2

Broadcast accept mode: accept

VLAN filter: disabled

Cononical form indicator: disabled

Discard pause frames: filtered

Pass MAC control frames: don't pass

Loopback mode: normal

Receive buffer size: 2048

0 Kudos
7 Replies
idata
Community Manager
116 Views

Hi Shreenik,

 

 

Thank you for sharing the information. I will further investigate on this

 

 

rgds,

 

wb

 

idata
Community Manager
116 Views

Hi Shreenik,

 

 

Currently we We don't have yet a definitive answer whether this is an expected behavior if both UPE and MPE are disabled.

 

 

We are still checking on this and we are seeing the same behavior as you are seeing.

 

 

Thanks,

 

wb

 

 

 

idata
Community Manager
116 Views

Sure thanks for looking into it, please let us know as soon as you have something to share. We need to fix it for a up coming release.

Thanks

-Shrinivas

idata
Community Manager
116 Views

Hi Shreenik,

 

 

Can you share What is the packet you are using and check if the destination address is really unicast vs. multicast. Thanks,

 

 

Rgds,

 

wb

 

idata
Community Manager
116 Views

Hi,

It is Unicast packet.

Thanks

-Shreeni

idata
Community Manager
116 Views

Hi Shreeni,

 

 

Thanks for the information.

 

 

rgds,

 

wb

 

idata
Community Manager
116 Views

Hi Shreeni,

 

 

Can you provide the packet information using packet analyzer?

 

 

 

Thanks,

 

wb

 

Reply