Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4536 Discussions

82578DC Error Code 10


Hello. I'm hoping this is posted in the correct place and that someone can help me.

I'm running Win 7 Professional x64. My computer automatically updated last night and this morning my network adapter is giving me an error 10 message. This is what I have and this is what I've done so far.

Adapter = 82578DC Gigabit adapter from Intel.

Core = i5 (entertainment core)

Win 7 x64 Professional Service Pack 1

It was working last night prior to the automatic update from Windows without issue.

I downloaded and installed the latest software for that adapter. Version = (date of driver Feb 2, 2012). The driver came as

part of a PROSet Version directly from Intel.

In the Network Connections Properties Tabs, I am told that the device status is, "This device cannot start. (Code 10)"

I've tried

  • Uninstalling the software and letting Windows install what it thinks it needs.
  • Disabling and re-enabling.
  • Rebooting everything.
  • I can't roll back to a previous patch as the hardware fails on both original drivers and the new ones I downloaded earlier today.

I suspect it's an esoteric registry entry that needs to be edited but I haven't the foggiest. I hoping someone can help. Thank you in advance.

0 Kudos
1 Reply

Hi Trevor,

Have you tried using a Windows restore point to return to a point before the updates? That might help even though rolling back the driver did not help. I have used Windows restore to go "back in time" to fix just about any weirdness that happened during an update or install of just about any type.

You have already tried the other things that I would normally suggest. Microsoft has a page on Code-10 Related Errors. I notice that when I land on that page, Microsoft has a Fix-It tool that offers to resolve hardware related issues. I have never used the tool, but if nothing else works, giving the tool a shot might be worthwhile.

Of course, the issue might be hardware related. You could try unplugging the network cable and unplugging devices from your USB port when you boot to see if the device comes up without the error code. Unplugging or disabling as much as possible will help lower power requirements in case you are encountering a power supply issue.

When you find a solution that works, please share it here.

Mark H

0 Kudos