Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4974 Discussions

82579LM No full/half duplex options work

idata
Employee
9,659 Views

Hi everyone,

I have an issue regarding the Intel 82579LM Gigabit Network card in a brand new HP PC (Windows 7 x64, latest NIC drivers from HP website)

I need the Link speed and Duplex set to 100Mbps - Full Duplex.

When I set this to 100/Full, or indeed any other option other than auto-negotiate, I lose my network connection immediately. (Network Connections shows Network cable unplugged.) If I set to auto-negotiate and reboot, I have the connection enabled without problem.

Leaving it at auto-negotiate is not an option. I need it set to 100/Full. I also have all of the following options disabled:

Adaptive Inter-Frame Spacing

Energy Efficient Ethernet

Flow Control

Checksum Offload

Interrupt Moderation

Jumbo Packet

Large Send Offload

Priority and VLAN

Protocal NS Offload

Receive Side Scaling

System Idle Power Saver

Wait for Link

and all Power management settings. Also Transmit/Receive Buffers set to 2048.

Any advice or suggestions welcomed. Am pulling my hair out here!

0 Kudos
29 Replies
Mark_H_Intel
Employee
1,269 Views

@gdburns65,

I assume you are already using the latest driver and have the latest BIOS. Are you using auto or trying to force the speed and duplex? I will send you a private message with some additional information.

Mark H

0 Kudos
idata
Employee
1,269 Views

I have the same problem here. Lenovo M91p with intel 82579LM network card cannot maintain its speed. Set to 100/FULL a few days later, reboot the PCs it drop back to 100/Half. I tried the new Intel driver no luck. Any solution??

0 Kudos
idata
Employee
1,269 Views

WORKAROUND:

 

Run regedit

Navigate to

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\XXXX

where XXXX is the key number (ie 0008) that pertains to the 82579LM adapter (do a search of the keys)

find the subkey "LinkNegotiationProcess". If the subkey is present, change the value to 2.

If subkey is not present, create it, add a string value and set it to 2

Exit regedit, reboot the system.

0 Kudos
Mark_H_Intel
Employee
1,269 Views

One of the engineers at Intel put together this utility to allow you to change the registry setting. Feel free to download it and give it a try. You should consider this utility to be beta quality since we have not put it through all the normal validation tests, but as far as we know, the utility has no bugs.

This utility has helped some people who have reported an issue where the speed and duplex negotiation gives unexpected results with some switches. By default, the 82579 connections always auto negotiate when you choose one of the "fixed" speed and duplex settings. The default behavior reduces the options advertised during speed and duplex negotiation. Using auto negotiation without advertising other speeds seems to work best with most link partners, but some switches need the FORCED mode that you can set with this utility. This utility will not help resolve other connection issues.

 

The instructions and download can be found at

 

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20585 http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20585.

 

After you use the utility to update the Windows registry, you must restart the adapter. You can restart Windows or use Windows Device Manager to disable and enable the network connection.

Also, we would love to hear back from you if this utility helped you or did not help you connect at the proper speed and duplex.

Mark H

0 Kudos
idata
Employee
1,269 Views

Thanks Mark,

One of my colleagues reported that the utility works. The solution I posted came from Lenovo Premier Support and seems to work fine for the M91p Thinkcenter.

0 Kudos
idata
Employee
1,269 Views

That linknegproc.exe works well, I've restarted 3 times this morning on 2 different PCs the connection stay at 100/Full. Thanks both of you.

0 Kudos
Mark_H_Intel
Employee
1,269 Views

I know that some of you have been affected by the duplex mismatch issue with the Intel 82579 Network Connections, so I wanted to let you in on what is going on. You can find bits and pieces of this information in other replies throughout the community, but I wanted to put everything I know ion the issue nto one post.

Let me start by making it clear how the driver (e1c) for the Intel 82579 Network Connections behaves when you configure one of the non-default speed and duplex options. The driver uses "selective advertisement" to negotiate a speed and duplex setting. For example, if you configure the network connection for 100 Mb, full-duplex mode, then that is the capability advertised to the link partner. This method works fine in most cases and usually avoids mismatches that can occur when two sides of a connection are forced to different settings. Unfortunately, as some of you have reported in this community, this method does not always work. Why not? Here is one case we have determined where "selective advertisement" does not work.

Intel has determined that the Intel 82579 Network Connection may not establish link properly to certain Cisco line cards that feature Cisco proprietary pre-standard Power over Ethernet (PoE) and have that feature enabled. The pre-standard PoE feature generates pulses on the cable that can be mistaken by the 82579 as an FLP advertising a 100Mb half-duplex mode auto-negotiation offer. If the Intel 82579 Network Connection is configured for 100 Mb full duplex, it will still start by attempting to auto-negotiate. If it mistakes the PoE pulse as a 100 Mb half-duplex offer, it will accept that offer and configure the interface for half-duplex, resulting in a duplex mismatch between the link partners. This, in turn, will result in extremely poor performance or a loss of communication.

If you are experiencing the duplex mismatch issue where you are trying to force 100 Mb, you have a few choices to work around the issue.

 

1. You could configure both sides for the default auto negotiation options.

 

2. You could disable Power over Ethernet on the switch port.

 

3. You could make a Windows registry change manually, by a script, or using a utility. This registry key change has been reported by several people to fix the issue.

Here is the registry key information in case you want to do this manually or need the values for your own tools or scripts.

 

• Registry Key: [REG_SZ] "LinkNegotiationProcess", with the following values:

 

• '1' (Auto-negotiate link). This is the default value.

 

• '2' (Force link speed for 10/100 Mbps link speeds). This is the value you will use as a workaround for the duplex mismatch issue.

The utility that you can use to make the registry change is available at:

 

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20585 http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20585.

I hope this information is helpful. I will let you know if I get more information.

Mark H

0 Kudos
idata
Employee
1,269 Views

hi Mark,

Good to see problem of many users getting solved. Not in my case. The download seems to be targeted to windows 7 PCs.

What if the operating system is Windows XP?

I tried all the options but none working out for me. Switches are fully managed L2, 10/100mb ethernet and PCs having gigabit adapters. Problem with motherboard having intel 82566DC Controller. Motherboard being intel Q963 chipset

Manish.

0 Kudos
Mark_H_Intel
Employee
1,269 Views

@Manish Shah

You might want to take a look at this thread:

/message/157816# 157816 http://communities.intel.com/message/157816# 157816.

I am not sure what your issue is, but the older driver found in the other thread might help.

The discussion in this thread is for a completely different hardware and driver, so the suggestions you try from this thread might not apply.

Mark H

0 Kudos
Reply