Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
1,354 Views

82579LM - Windows 8 issue with ProSet and vlans with static addresses

Jump to solution

I am testing Windows 8 Enterprise 64 on an Intel DQ67SW motherboard. It has an 82579LM network card which I've installed with the newer ProSet 17.4 for Windows 8 (64bit) (also tried 17.3 with same results). Here is my problem : If I add a tagged VLAN and I set it with a static IPv4 address, the network card accepts it but keeps the "autoconfiguration IPv4 Address" (169.254.171.226) also and marks it has . Hence the network card is useless and routes aren't being set properly.

ipconfig /all :

Ethernet adapter Ethernet 2:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Intel(R) 82579LM Gigabit Network Connection - VLAN : VLAN1000

Physical Address. . . . . . . . . : 00-22-4D-6B-59-C5

DHCP Enabled. . . . . . . . . . . : No

Autoconfiguration Enabled . . . . : Yes

Link-local IPv6 Address . . . . . : fe80::75e5:55c9:c10e:abe2%26(Preferred)

IPv4 Address. . . . . . . . . . . : 10.0.10.5(Duplicate)

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Autoconfiguration IPv4 Address. . : 169.254.171.226(Preferred)

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . :

DHCPv6 IAID . . . . . . . . . . . : 436216397

DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-36-4E-E6-00-22-4D-6B-59-C5

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

fec0:0:0:ffff::2%1

fec0:0:0:ffff::3%1

NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

DHCP Enabled. . . . . . . . . . . : No

Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{CAAE7C0F-9462-45E9-9266-2E79108C7F24}:

Media State . . . . . . . . . . . : Media disconnected

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Microsoft ISATAP Adapter # 3

Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

DHCP Enabled. . . . . . . . . . . : No

Autoconfiguration Enabled . . . . : Yes

any help? I've used ProSet drivers since forever on all past windows OS and that same problem never occured... so I guess it's a case of immature drivers?

0 Kudos

Accepted Solutions
Highlighted
Community Manager
49 Views

Alright so this all was a HUGE code 18 on my part.

I am building my "new" PC at work alongside my working one... and like an idiot I set up the same static IP on both! When I reverted to installing Windows 7 it popped-up an IP address conflit message which Windows 8 never popped!

So I went back to Windows 8 making sure to have different IPs and all is well.

No bug in the drivers, simply bad handling on my part.

thanks for the help Mark H.!

View solution in original post

0 Kudos
4 Replies
Highlighted
Employee
49 Views

Hi Alex,

I have seen instances in earlier versions of Windows where the Windows network connection interface took awhile to initialize, and if you configure a static IP before the interface completed initialization, the static IP address failed. I think this might be what happened to you.

Try this:

  1. Remove the VLAN.
  2. Wait 60 seconds
  3. Create a VLAN using the VLAN tab.
  4. Do something else for a few minutes. A few minutes is probably longer than needed, but I don't know how to tell when it is safe to assign the static IP address.
  5. Assign a static IP address to the VLAN interface.

I hope this helps.

Mark H

0 Kudos
Highlighted
Community Manager
50 Views

Alright so this all was a HUGE code 18 on my part.

I am building my "new" PC at work alongside my working one... and like an idiot I set up the same static IP on both! When I reverted to installing Windows 7 it popped-up an IP address conflit message which Windows 8 never popped!

So I went back to Windows 8 making sure to have different IPs and all is well.

No bug in the drivers, simply bad handling on my part.

thanks for the help Mark H.!

View solution in original post

0 Kudos
Highlighted
Employee
49 Views

I have to try to remember this symptom. Maybe Windows 8 calls an IP conflict a "duplicate." I hadn't thought of that when you shared the ipconfig information. Maybe Windows 8 is trying to be helpful by assigning an automatic address instead of warning of an IP conflict. I will watch for that situation in the future.

I am glad your issue is resolved. Have a great day.

Mark H

0 Kudos
Highlighted
Community Manager
49 Views

that would indeed make sense! Still they could've kept the useful pop-up to let us know that we just did something wrong on the network.

have a good one!

0 Kudos