Ethernet Products
Intel® Ethernet products and technologies
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
3971 Discussions

82579LM and WDS/Ghost

Community Manager

I purchased an HP 6200 which came with the 82579LM 1g network chip.

For the life of me i cannot get this card to work with WDS or Ghost.

I have added the e1c6232 along with the 6023 and 5123 drivers to my boot.wim and still no network.

Same drivers added to my ghost image. same result.

I have an Elitebook with the 82567LM chip and that works.

I downloaded the PROWin32.exe, extraced the drivers and added every .inf file contained inside to the .wim file and ghost. that didnt work for either ghost or wds.

I've been on the Symantec forums and they suggested using the Vista drivers. Those are in the PROWin32.exe file.

Hopefully someone here can help.

0 Kudos
6 Replies
New Contributor III

1. Which version of WinPE are you using?

2. Are there more than one image contained within the boot.wim(s) you're using (index:1 index:2 etc.)?

Community Manager

Im using ghost boot wizard version

There are 2 images in the boot.wim file.

I'm adding drivers to both index 1 and 2

I used imagex from server 2003 and dism from an r2 server.

Both report no errors and that the drivers were loaded.

I verify this by the growing file size of the boot.wim

I delete the boot file from WDS and then add an image vs. replacing the image.

I input the e1c6032 drivers into the winPE from ghost about 5x and that finally works.

Still cannot get it to work from WDS though, from either a 2003 server or R2 server.

New Contributor III

ocitman wrote:

Still cannot get it to work from WDS though, from either a 2003 server or R2 server.

What exactly do you mean here? That the image (boot.wim) doesn't boot from WDS (PXE), or that there is no network connection available from within WinPE once it has booted from WDS?

To make sure the drivers were installed within the image, you can manually inspect the FileRepository once WinPE boots: X:\Windows\System32\DriverStore\FileRepository (looking for e1c6032), or you can open and inspect the oem inf files (oem0.inf, oem1.inf etc.) in the X:\Windows\Inf directory.

I can't remember off the top of my head whether Dism works with WinPE 2.0 or not, but this will give you a 3rd party driver list of your mounted boot.wim:

Dism /image:%mountpath% /Get-Drivers

You can also try drvload to manually load the network driver from within WinPE once the image has booted: drvload e1c6032.inf

then /release /renew with ipconfig (assuming DHCP).

I use WinPE 3.0 with Ghost from WDS all the time, and I have had no issues with the 82579LM. I didn't use the Ghost Boot Wizard to build it though, I manually created it using the Windows OPK.

Community Manager

So to clarify my question...

I can boot the computer from my ghost boot flash drive successfully.

Then I run a" net use" command and map a drive containing the .gho file I need.

This completes successfully so the NIC drivers in using, e1c6032, are working properly.

So I added the same NIC drivers to my boot.wim file for WDS.

I can successfully network boot into WDS but I get and error message

"The image does not contain the correct network card driver. Please ask your admin to install them in the WinPE boot image."

(not a direct quote but something like that)

I will try what you suggested...

Dism /image:%mountpath% /Get-Drivers

and verify that the drivers are indeed installed.

You can also try drvload to manually load the network driver from within WinPE once the image has booted

I cannot try this from WDS since I can't get past the error message stated above.

What I do is install a fresh copy of Win 7 from WDS so that I can use my volume license key.

ThenIi add whatever software needs to be installed, and make a ghost image of that.

Sometimes i make a .wim file of the image if the server I'm going to place it on has ample space.

Thanks for helping me sort this out

Community Manager


Thanks for the heaps of information.

What i did was looked at the info stored in my boot.wim.

It showed the drivers installed along with everything else installed and i didnt understand why it was not working.

So i pulled a new boot.wim from a W7 dvd and installed just the e1c6232, e1c6032, iastor and iaahci drivers into both image indexes...for the 3rd time.

That must have done it since i was able to boot successfully.

I did this on Server 2003 using imagex.

Now i will export that image and try it from my R2 server

New Contributor III

Awesome, glad I could help.