Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
4355 Discussions

82579LM won't link at 100 Full Duplex on Cisco 6500 (modules WS-X6148-RJ45V)



In my company we have discovered that all the computers we have with the ethernet controller Intel 82579LM (HP Z210 & Lenovo Thinkpad T420) are unable to link at 100 MB Full Duplex when connected to certain Cisco Switch modules.

All the switches have all their ports set to forced 100 MB Full Duplex, and all computers are configured to forced 100 MB Full Duplex.

This configuration works fine for all other computers in the company (6000+) and also on the other switch modules we have.

On the client computers with the 82579LM we have tried to connect them directly to the switch modules we have and so far this is what we have found.

Switch ModuleClient settingLink speed resultCisco 6500 WS-X6548-GE-TX100 MB Full Duplex100 MB Full DuplexCisco 6500 WS-X6348100 MB Full Duplex100 MB Full DuplexCisco 6500 WS-X6148-RJ45V100 MB Full Duplex100 MB Half DuplexCisco 6500 WS-X6148-RJ45VAuto100 MB Half DuplexCisco 4506 WS-X4146-RJ100 MB Full Duplex100 MB Full Duplex

The client computers are all running Windows 7 Enterprise x64 SP1, and we tested this with the default Windows driver and Intel's newest Proset 16.7 ( & Proset 16.8 ( but the same result every time. For compability reasons with other equipment the switch ports have to be set at 100 MB Full duplex so that can't be changed. I also tried setting the "Wait for link" to auto, off, and on but no change.

Also we have checked that the computers we tested on where on the newest BIOS version available from HP & Lenovo.

This is either a bug in the driver or an hardware defect in 82579LM.

How do we fix this? We have about 1000 of these HP Z210 and about 300 Lenovo T420's

0 Kudos
4 Replies
New Contributor I

In our company I had really bad experience with enforced speed settings on Cisco switches. No matter what was set on client side, behavior was hard to predict, includind unexpected link losses etc. Especially with devices such as Brocade's Fibre Channel Enterprise Directors (devices that I manage) or EMC Clariion disk arrays.

Out network team was insisting on enforced speed settings (for reasons unknown to me) on Cisco side but once they swithed the setting to Auto everything went back to normal.

Thus my advice would be to at least giving a try to Auto option on Cisco side. If linkspeed needs to be enforced, try enforcing on client side only.


As stated in first post we have to have the Switches set at 100 full duplex, we can't micromanage port configuration.


Still no news yet, this is a major problem in our company now, and looking at the other threads regarding 82579LM it seems we are not the only ones with this issue.

Does anyone know how to formally submit this bug to Intel so we can get someone to look at this.


Never mind I found the link to the linknegproc.exe util in the other thread /thread/23859?start=15&tstart=0

This util solves the problem for us as well.

But I'm confused as to why the the network controller still does auto negotiation when the driver is set to forced. I mean why present the user with the option to change speed and duplex settings if it's just getting ignored anyway.

Maybe this should be fixed in the next driver release.