Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4620 Discussions

Any resolution for onboard 82578dc NIC Code 10 Error?


I have a EVGA socket 1156 micro-ATX motherboard. It has Intel's P55 V chipset with their 82578dc onboard NIC. When cold booting into windows 7 x64, the device encounters error code 10 (device will not start). To get it to work, I have to manually go into Windows device manager and disable the NIC and then enable it. As you can imagine, this is not an enduring solution. With a Google search, I've discovered this error/problem is quite prevalent with intel onboard NICs. There are no viable solutions (at least none from Intel). Most are community developed workarounds (ex. scripts to automatically disable and enable the NIC).

Other notes:

  • I have the latest chipset drivers (used both motherboard and Intel)
  • I have the latest NIC driver (Intel PROset x64)
  • I have the latest BIOS from the motherboard manufacturer.
  • The NIC has this issue on a fresh install of Windows 7 x64.

What I've found:

I believe this to be a BIOS to windows hand off issue (IE. Intel driver issue). During system POST, the BIOS assigns the NIC the typical Ethernet IRQ 11. In windows, with the code 10 error, no other device I have is assigned IRQ 11, so there shouldn't be a conflict causing the device to not start or use that IRQ. After disabling/enabling the NIC however, it is assigned IRQ 4294967294 (displayed as "-2" in the device manager resources), which seems quite odd. So I think IRQ assignment is where the problem lies. This is where I am hung up. Users used to have a way to manually assign IRQs, but IRQ issues have (supposedly) become extinct, so I can't find any options on trying to force an IRQ assignment.


Has this issue been resolved yet? All the forum threads I've seen on this issue have been dead ends/abandoned. Does this IRQ assignment oddity spark any ideas? Has anyone tried forcing IRQ assignments for the NIC in the registry?

0 Kudos
2 Replies

Hi Old_Newbie, if you've already loaded the latest driver posted in, you may want to look into other suggestions posted in microsoft KB - Fix: "This device cannot start" Code 10 error in Device Manager in Windows to further isolate the issue.


have you tried loading another operating system than windows 7?


0 Kudos

I have the latest mobo BIOS, Intel chipset, and Intel x64 proset driver. Haven't tried any other OS (since this was a fresh Win 7 x64 install). In the many threads I've read on this issue, there have been folks with XP 32bit that didn't have the issue then upgraded to Win 7 x64 and got the issue. Even folks with Linux have had the issue with the Ethernet failing to initialize from cold boot as well (although their community was pretty quick to mod Intel's drivers and fix).

All have been some form of the intel _55 chipset (P55, DH55, etc) with an onboard 8257___(82578DC, 82579V, etc.) gigabit Ethernet.

Bug in firmware?

0 Kudos