Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JKiss2
Novice
3,431 Views

Bad impressions of the network card after driver update.

I use original network card Intel 82574L (EXPI9301CTBLK). After the upgrade, with the built-in "Windows 7 x64" driver 11.0.5.22 to the last 12.7.28.0 there are delays in downloading web pages. There is a general slowdown. Why are there new drivers slow down? After roll back to version 11.0.5.22 everything becomes normal.

PS And in the driver confused modes FullDuplex (Half) and HalfDuplex (Full).

0 Kudos
18 Replies
st4
New Contributor III
139 Views

Hi John Kiss,

Thank you for the post. I am sorry to hear what happened , there are many factors that affects slow down. Have you tried changing the cable, or did you made any changes on the system?

For the transmission mode, by default Gigabit speed is in full duplex mode or you can use autonegotiation.

rgds,

wb

JKiss2
Novice
139 Views

On the cable there is no problem. Ping 1ms, no packet loss. On page load delay only affects the driver update.

PS: The rate used 100 Mbps. Enables 100 Mbps Half Duplex and download speed becomes 100 Mbps. With mode 100 Mbps Full Duplex - 8-10 Mbps maximum for downloading. How is this possible? The provider uses a switch D-Link DES-3526. When I use the Realtek network card is no such problem.

st4
New Contributor III
139 Views

Hi John Kiss,

Please make sure to use autonegotiation or gigabit speed.

Make sure the setting on the switch is gigabit or autonegotion is the switch is manageable.

rgds,

wb

JKiss2
Novice
139 Views

And what to do with the delay in loading pages with updated drivers? Stay on older drivers?

st4
New Contributor III
139 Views

Hi John Kiss,

Did you try re-installing the driver? Have you had another system (in case you have) for you to test if the same issue will occur on the CT desktop adapter?

Thanks,

wb

JKiss2
Novice
139 Views

Of course I reinstalled. Many times. How else would I know about this problem? Another PC is not available. The problem in the driver. With the old driver 11.0.5.22 works perfectly. Maybe you need any more information? Ask.

st4
New Contributor III
139 Views

Hi John Kiss,

Can you share what is the website where you download the driver?

thanks,

wb

st4
New Contributor III
139 Views

Hi John,

Thanks for sharing the link. Will check on this.

rgds,

wb

st4
New Contributor III
139 Views

Hi John,

Good day. We did some testing and sharing here our simulation result. So far we did not encounter the slow page load problem. Please see detail below:

Driver version: 12.7.28.0

Advance setting in the NIC:

 

Flow control - Rx & Tx Enabled

 

InterruptModeration - Enabled

 

IPchecksumoffload IPv4 - Rx & Tx Enabled

 

JumboPacket - Disabled

 

Large send offload IPv4 - Enabled

 

Large send offload IPv6 - Enabled

 

Priority & VLAN - enabled

 

Received buffers - 256

 

Receive Side scaling - enabled

 

speed and duplex - Auto negotiation

 

TCP checksum offload IPv4 - Enabled

 

TCP checksum offload IPv6 - Enabled

 

UDP checksum offload IPv4 - Enabled

 

UDP checksum offload IPv6 - Enabled

 

transmit buffers - 512

 

Wake on magic packet - enabled

 

wake on pattern match - enabled

 

adaptive inter-frame spacing - disabled

 

enabled pme - disabled

 

interrupt moderate rate - adaptive

 

log link event - enabled

 

gigabit master slave mode - auto detect

 

local administered address - none

 

receive side scaling queues - 1

 

reduce speed on power down - 1

 

wait for link - auto detect

 

wake on link settings - disabled

 

Please try the following:

 

1)Use older driver version 20.1, 20.2 to see if this will make any difference:

version 20.2

 

https://downloadcenter.intel.com/download/25242/Network-Adapter-Driver-for-Windows-7-?product=50395 https://downloadcenter.intel.com/download/25242/Network-Adapter-Driver-for-Windows-7-?product=50395

version 20.1

 

https://downloadcenter.intel.com/download/25112/Network-Adapter-Driver-for-Windows-7-?product=50395 https://downloadcenter.intel.com/download/25112/Network-Adapter-Driver-for-Windows-7-?product=50395

2)Disable onboard NIC to check if there's improvement on CT adapter

 

3) Can you please provide the steps on how you encountered the "page load slow" issue

4) Please download and run the SSU to provide me the xml file. You may attach the log file in the post

 

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

Thanks,

wb

JKiss2
Novice
139 Views

I did not mean slow loading pages. A mean delay before the page loads. With the driver e1q60x64 - 11.0.5.22 page loaded immediately. Above this version there is a delay. Disabling onboard NIC does not help. Try to use the older driver. I send it to you. https://onedrive.live.com/?authkey=!AMtaD92cvvIDH3U&id=ED56934E6CD60822!414&cid=ED56934E6CD60822 https://onedrive.live.com/?authkey=!AMtaD92cvvIDH3U&id=ED56934E6CD60822!414&cid=ED56934E6CD60822

And then compare the work with the new version.

st4
New Contributor III
139 Views

Hi John,

Thank you for the clarification. Does this issue occur if you are using a different browser?

Just to double check,

When you open the browser type in the URL, with version 11, the webpage would load immediately, but with the newer version the page will not load immediately as you mentioned, do you mind telling me like how many seconds is the delay?

Thanks.

rgds,

wb

JKiss2
Novice
139 Views

Yes. Now you understood me correctly. I think the browser is not important. Because Windows 10 (Edge) with a new driver, too, have this problem. The delay may be from 1 to 3 seconds.

st4
New Contributor III
139 Views

Hi John,

Thank you for the clarification. Will further check on this.

rgds,

wb

st4
New Contributor III
139 Views

Hi John,

The SSU log shows there is no conflict between driver version 11 and 12. We are not able to replicate your

 

issue as we did not encounter the loading page issue. We use IE 11 and access Intel website and open another tab accessing another intel website, there was no mean delay.

 

Can you help provide the serial number of the CT desktop adatper? You can check on this website

 

about the location of the serial number

 

http://www.intel.com/content/www/us/en/support/network-and-i-o/ethernet-products/000007022.html http://www.intel.com/content/www/us/en/support/network-and-i-o/ethernet-products/000007022.html

It is three sets of alphanumeric e.g. 00xxxxxxxxxx xxxxx xxxxxx-xxx

Thanks,

 

wb
JKiss2
Novice
139 Views

serial number 001B21C40743 291CR E46981-006

st4
New Contributor III
139 Views

HI John,

Thank you for the information.

rgds,

wb

st4
New Contributor III
139 Views

Hi John,

Good day. I would like to check with you if it is OK for you if we will replace your network adapter.

Thanks,

wb

Reply