Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,686 Views

Can't get 25G to link up back to to back (XXV710) Linux 16.04

I have Silicom quad http://http//www.silicom-usa.com/pr/server-adapters/networking-adapters/25-gigabit-ethernet-networki... 25G NIC's, it is using XXV710-AM2.

I'm using Avago 25G-SR http://www.foxconnconnector.com/sale-9183978-avago-afbr-725smz-25-gbd-mmf-sfp-optical-transceiver-fo... SFP, and I have two interfaces hooked up back to back, I can't get a link.

I'm using the latest and greatest i40e driver (version 2.4.10)

This is what I see from ethtool

apcon@utraffic25:~/working/drivers/hw_debug$ sudo ethtool enp59s0f0

Settings for enp59s0f0:

Supported ports: [ ]

Supported link modes: 1000baseT/Full

Supports auto-negotiation: Yes

Advertised link modes: 1000baseT/Full

10000baseT/Full

Advertised auto-negotiation: Yes

Speed: Unknown! (65535)

Duplex: Unknown! (255)

Port: Unknown! (255)

PHYAD: 0

Transceiver: internal

Auto-negotiation: off

Supports Wake-on: g

Wake-on: g

Current message level: 0x0000000f (15)

Link detected: no

apcon@utraffic25:~/working/drivers/hw_debug$ sudo ethtool -i enp59s0f1

driver: i40e

version: 2.4.10

firmware-version: 6.02 0x80003a08 1.1691.0

bus-info: 0000:3b:00.1

I see link LED's responding just fine on the hardware, but I don't see the link state changing from linux

So my initial suspicions are:

1. Non-Intel SFP's are just not supported. Which is really odd for Intel NICs since all my 10G and 40G Intel NICs work wirth Avago.

2. Do I have to pass some drivers parameters to i40e?

Tags (1)
0 Kudos
9 Replies
Highlighted
Community Manager
121 Views

Hello Morgany,

Thank you for posting in Intel Wired Ethernet Communities. Are both adapters being used the same model, If you connect to another device will it work? Please check that the PCI-e interface is 3.0 supporting full 8X on your system. Please see the following https://www.intel.com/content/www/xa/en/support/articles/000023708/network-and-i-o/ethernet-products... link for SFP28 compatibility with XXV710. We only list one Intel module. You may verify additional supported modules with Silicom, and check if they provide additional drivers or firmware. Please let us know if you have other questions.

Best regards,

 

Daniel D

 

Intel Customer Support

 

Agent under contract to Intel
0 Kudos
Highlighted
Beginner
121 Views

Hi Daniel:

To answer your question.

1. The two interfaces on the same card. I also tried plugging into an identical card on the same system. I bought 6 identical cards.

2. All cards are on PCI-E 3.0 compliant interfaces. I have verified this.

3. The cards were shipped with firmware 6.0.2, I did not have to update this via NVM

Again, I notice the LED's are showing active links, just not the driver stack.

Thanks

Morgan

0 Kudos
Highlighted
Community Manager
121 Views

Hello Morgany,

 

 

Thank you for the information. Did you also verify the module compatibility with Silicom? From the image provided the ACT link LED appears to be off on the left port; please confirm if it is off or blinking. Have you used the same cable for each test? Would you be able to see if one of the adapters can detect a link from another system or OS? Please provide ifconfig output, modprobe i40e followed by dmesg output, as well as lshw -class network. Will investigate the issue further with the information provided.

 

 

Best regards,

 

Daniel D

 

Intel Customer Support

 

Agent under contract to Intel
0 Kudos
Highlighted
Community Manager
121 Views

Hello Morgany,

 

 

Please let us know if you still need assistance with this issue. If you solved this issue, please inform us. If you have any questions please do not hesitate to ask.

 

 

Best regards,

 

Daniel D

 

Intel Customer Support

 

Agent under contract to Intel
0 Kudos
Highlighted
Beginner
121 Views

Hi:

Sorry for the delay. It turns out I was able to get link up running Ubuntu 18.04

apcon@utraffic25:~$ sudo ethtool enp94s0f0

Settings for enp94s0f0:

Supported ports: [ FIBRE ]

Supported link modes: 25000baseSR/Full

Supported pause frame use: Symmetric

Supports auto-negotiation: Yes

Supported FEC modes: Not reported

Advertised link modes: 25000baseSR/Full

Advertised pause frame use: No

Advertised auto-negotiation: Yes

Advertised FEC modes: Not reported

Speed: 25000Mb/s

Duplex: Full

Port: FIBRE

PHYAD: 0

Transceiver: internal

Auto-negotiation: off

Supports Wake-on: g

Wake-on: g

Current message level: 0x00000007 (7)

drv probe link

Link detected: yes

apcon@utraffic25:~$ sudo ethtool -i enp94s0f0

driver: i40e

version: 2.1.14-k

firmware-version: 6.02 0x80003a08 1.1691.0

expansion-rom-version:

bus-info: 0000:5e:00.0

supports-statistics: yes

supports-test: yes

supports-eeprom-access: yes

supports-register-dump: yes

supports-priv-flags: yes

Now, the strange news, I have a quad NIC, but only 2 out of 4 NIC's are initialized by the driver. In fact, running "lspci" only shows 2 25G interfaces on that particular PCI address

-+-[0000:d7]-+-00.0-[d8]--+-00.0 Intel Corporation Ethernet Controller XXV710 for 25GbE SFP28

| | \-00.1 Intel Corporation Ethernet Controller XXV710 for 25GbE SFP28

| +-05.0 Intel Corporation Device 2034

| +-05.2 Intel Corporation Sky Lake-E RAS Configuration Registers

| +-05.4 Intel Corporation Device 2036

| +-0e.0 Intel Corporation Device 2058

| +-0e.1 Intel Corporation Device 2059

| +-0f.0 Intel Corporation Device 2058

| +-0f.1 Intel Corporation Device 2059

| +-12.0 Intel Corporation Sky Lake-E M3KTI Registers

| +-12.1 Intel Corporation Sky Lake-E M3KTI Registers

| +-12.2 Intel Corporation Sky Lake-E M3KTI Registers

| +-15.0 Intel Corporation Sky Lake-E M2PCI Registers

| +-16.0 Intel Corporation Sky Lake-E M2PCI Registers

| \-16.4 Intel Corporation Sky Lake-E M2PCI Registers

So the good news i'm getting a link. But news is i'm only getting 2 out of 4 interfaces

0 Kudos
Highlighted
Community Manager
121 Views

Hello Morgany,

Please let us know the brand and model of the system these network adapters are being used on. All 4 ports are connected to another identical adapter on the same system? Are the two detected interfaces constant even after a reboot or power cycle, or do they alternate? Are all of the link lights still on, or just 2 of the ports? Kindly contact Silicom to confirm compatibility with the system and SFP modules. Please let us know if you have any questions.

Best regards,

 

Daniel D

 

Intel Customer Support

 

Agent under contract to Intel
0 Kudos
Highlighted
Community Manager
121 Views

Hello Morgany,

 

 

Please let us know if you still need assistance with this XXV710 controller. We have not received a reply in some time. Please do not hesitate to reply if you no longer need assistance, or have any questions.

 

 

Best regards,

 

Daniel D
0 Kudos
Highlighted
Community Manager
121 Views

Hello Morgany,

 

 

Have you managed to resolve this issue? Please let us know if you still have any questions.

 

 

Best regards.

 

Daniel D
0 Kudos
Highlighted
Beginner
121 Views

سلام ایا شما تابحال به سایت هایی که اصلا ربطی به اینتل ندارند سر زدید ؟ اگر به بحث های عطر و ادکلن علاقه مندید حتما به سایت زیر یر بزنید

https://atrpich.com/product/mont-blanc-legend-mens-eau-de-perfume/

0 Kudos