Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BWong9
Beginner
5,485 Views

Cannot PXEboot with Intel X710 NIC (pxe structure was not found in UNDI driver code segment)

Hello, I've been having trouble with this NIC not booting off of PXE. I've already set the 10Gbe interface as a booting interface in the BIOS. During PXE, I get the error message: PXE structure was not found in the UNDI driver code segment. When it first didn't work, I used nvmupdate64e to update the NIC firmware. nvmupdate now tells me my firmware is up to date (at version 6.01). However, I still get the same exact error message at PXE boot. I have also tried enabling PXE flash firmware for the interfaces. But I still get the same error after all these driver installs and configuration enables.

lspci -vv | grep -i 'Intel Corporation Ethernet Controller X710'

81:00.0 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)

81:00.1 Ethernet controller: Intel Corporation Ethernet Controller X710 for 10GbE SFP+ (rev 01)

./bootutil64e

Port Network Address Location Series WOL Flash Firmware Version

3 6805CA385DF0 129:00.0 40GbE N/A UEFI,PXE Enabled 1.0.66

4 6805CA385DF1 129:00.1 40GbE N/A UEFI,PXE Enabled 1.0.66

ethtool -i eth2

driver: i40e

version: 1.5.10-k

firmware-version: 6.01 0x80003483 1.1747.0

bus-info: 0000:81:00.0

./nvmupdate64e

Num Description Ver. DevId S:B Status

01 Intel (R) I350 Gigabit Network Connection 1.99 1521 00:0001 Update not available

02 Intel(R) Ethernet Converged Network 6.01 1572 00:129 Up to date

Adapter X710-2

Any idea what I need to do to get this interface to PXEboot? eth2 is the interface that I am using.

0 Kudos
13 Replies
idata
Community Manager
1,849 Views

Hi Ubentu,

 

 

Thank you for posting in Wired Communities. Please try to re-flash the image of the pxe boot, you may refer to below websites for more information:

 

 

https://www.intel.com/content/www/us/en/support/articles/000005992/network-and-i-o/ethernet-products...

 

 

https://www.intel.com/content/www/us/en/support/articles/000005790/software/manageability-products.h...

 

 

Regards,

 

Sharon T
idata
Community Manager
1,849 Views

Hi Ubentu,

 

 

Please feel free to update us if further assistance needed, we would like to know the test result so that we can better assist you.

 

 

Regards,

 

Sharon T
BWong9
Beginner
1,849 Views

Hi Sharon,

I've tried to reflash the PXE boot image several times with older images and up to date ones. I still receive the same error. Please see my attached.

idata
Community Manager
1,849 Views

Hi Ubentu,

 

 

Thank you for the update and providing additional information. Please refer to page 18 of below documentation for the error message:

 

https://www.intel.com/content/dam/support/us/en/documents/network-and-i-o/ethernet-products/Boot_Age...

 

 

The PXE-EC8 error is an indication the Boot Agent could not locate the required PXE structure resource Possible cause

 

could be the memory bar being set above the 4G boundary. Please refer to the above link for more detail.

 

 

Thanks,

 

Sharon T
idata
Community Manager
1,849 Views

HI Ubentu,

 

 

Please let me know if you have refer to the information and tried the suggestion, in case this does not work, please provide more information for better investigation.

 

 

Regards,

 

Sharon T
CStac
Beginner
1,849 Views

What you are saying is that with this network card, we have to pick between +4GB Enabled Memory Bar or PXE booting? A choice between my accelerators or my automated work flow? That is an awful choice.

Sadly I confirmed - for me - that disabling the 4GB boundary enables PXE.

Looks like I'm in the market for a new network card...

idata
Community Manager
1,849 Views

Hi Ubentu,

 

 

Here is what you can try in case your BIOS is UEFI capable. You can implement a UEFI-based solution instead of legacy PXE. Memory addressing is not a limitation of the UEFI environment.

 

 

Hope this helps.

 

 

Regards,

 

Sharon T
idata
Community Manager
1,849 Views

Hi Ubentu and I.am.Stack,

 

 

 

Please let us know if further assistance needed. Looking forward to your reply.

 

 

Thanks,

 

Sharon T
BWong9
Beginner
1,849 Views

Hi Sharon,

I tried setting the boot mode to UEFI and changed the PCIe settings to EFI I still can't get my server to see the Intel X710 as a possible boot device. Here's the output of Intel booutil and NVMUpdate. Any hints regarding that?

# ./nvmupdate64e

Intel(R) Ethernet NVM Update Tool

NVMUpdate version 1.30.22.1

Copyright (C) 2013 - 2017 Intel Corporation.

WARNING: To avoid damage to your device, do not stop the update or reboot or power off the system during this update.

Inventory in progress. Please wait [........**]

Num Description Ver. DevId S:B Status

=== ======================================== ===== ===== ====== ===============

01) Intel(R) I350 Gigabit Network Connection 1.99 1521 00:001 Update not

available

02) Intel(R) Ethernet Converged Network 6.01 1572 00:009 Up to date

Adapter X710-2

Tool execution completed with the following status: All operations completed successfully

Press any key to exit.

# ~/intel_preboot/APPS/BootUtil/Linux_x64/bootutil64e

Intel(R) Ethernet Flash Firmware Utility

BootUtil version 1.6.57.0

Copyright (C) 2003-2017 Intel Corporation

Type BootUtil -? for help

Port Network Address Location Series WOL Flash Firmware Version

==== =============== ======== ======= === ============================= =======

1 0CC47A50844A 1:00.0 Gigabit NO FLASH Not Present

2 0CC47A50844B 1:00.1 Gigabit NO FLASH Not Present

3 6805CA385DF0 9:00.0 40GbE N/A PXE 1.0.66

4 6805CA385DF1 9:00.1 40GbE N/A PXE 1.0.66

idata
Community Manager
1,849 Views

Hi Ubentu,

 

Thank you for the information. Let me further check.

Regards,

 

Sharon T

Intel Customer Support

Agent under contract to Intel

idata
Community Manager
1,849 Views

Hi Ubentu,

 

 

Please try set PXE to EFI by executing the following command:

 

 

bootutil -nic=3 -up=efi

 

 

Regards,

 

Sharon T

 

Intel Customer Support

 

Agent under contract to Intel
idata
Community Manager
1,849 Views

Hi Ubentu,

 

 

Please feel free to update me if you have tried the command and if works for you.

 

 

Regards,

 

Sharon T

 

Intel Customer Support

 

Agent under contract to Intel
idata
Community Manager
1,849 Views

Hi Ubentu,

Have you tried the command already? Please feel free to update us.

Regards,

 

Sharon T

 

Intel Customer Support

 

Agent under contract to Intel

 

Reply