Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4919 Discussions

Different subsys ID on ports of Cisco-Intel X710-DA2

brad_cve
Beginner
880 Views

Hi all,

We are running into an issue with an AzureStack HCI deploy using X710-DA2s for the management and compute roles.

 

Per the Windows Server Catalog, these NICs are supported for these roles under Server 2022.

 

https://www.windowsservercatalog.com/item.aspx?idItem=56C25134-3470-D029-07B2-578B69E0541D&bCatID=1466

 

In troubleshooting a failed AzureStack HCI deploy via Azure, we found the following:

PS C:\Users\Administrator> Add-NetIntent -ClusterName null-azs01-cl  -AdapterName "ethernet", "ethernet 2" -Name man-comp -Compute -Management
 -- Creating a new intent with name man-comp
 -- Compute intent was submitted
 -- Management intent was submitted
 -- Checking if exact intent request 'man-comp' already exists
 -- Checking if specified physical adapters conflict with an existing intent
 -- Validating if physical NICs with the name exist on the remote server(s) and are status 'Up'
 -- Validating network adapters and virtual switch on all the following nodes
null-azs01-01 null-azs01-02
 -- Found ethernet on null-azs01-01
 -- Found ethernet 2 on null-azs01-01
 -- Validating physical NICs on null-azs01-01 are symmetric
 -- FAILED: Intent request for man-comp failed to be submitted.
          : ExceptionDetails:
          : The network adapters included in the intent are not symmetric (ComponentID)
-- null-azs01-01 (Ethernet, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_00001137)
-- null-azs01-01 (Ethernet 2, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_020A1137)
-- null-azs01-02 (Ethernet 2, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_020A1137)
-- null-azs01-02 (Ethernet, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_00001137)

The network adapters included in the intent are not symmetric (ComponentID)
-- null-azs01-01 (Ethernet, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_00001137)
-- null-azs01-01 (Ethernet 2, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_020A1137)
-- null-azs01-02 (Ethernet 2, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_020A1137)
-- null-azs01-02 (Ethernet, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_00001137)
At C:\Windows\system32\WindowsPowerShell\v1.0\Modules\NetworkATC\NetworkAtc.psm1:1327 char:13
+             throw $errorMsg
+             ~~~~~~~~~~~~~~~
    + CategoryInfo          : OperationStopped: (The network ada...SYS_00001137)
:String) [], RuntimeException
    + FullyQualifiedErrorId : The network adapters included in the intent are not symmetric (ComponentID)
-- null-azs01-01 (Ethernet, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_00001137)
-- null-azs01-01 (Ethernet 2, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_020A1137)
-- null-azs01-02 (Ethernet 2, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_020A1137)
-- null-azs01-02 (Ethernet, 10 Gbps, PCI\VEN_8086&DEV_1572&SUBSYS_00001137)

 

The issue seems to stem from ports 1 and 2 having different subsys IDs, 00001137 vs 020A1137. That seems odd and not something we see in other dual or quad port NICs. Any thoughts on why the ports have different subsys IDs, and whether there's any way to modify them?

0 Kudos
10 Replies
Alreanaes
Beginner
813 Views

I am having this exact same issue. Unfortunately, it looks like this is a known errata for the 700 series.

2. PCIe Subsystem ID Incorrectly Reported for All PCI Functions Except Function 0
Problem:
All PCIe functions except Function 0 report a Subsystem ID of 0x0000 in the configuration space
(including related Virtual Functions) regardless of the value programmed in the NVM.
Implication:
No functional impact to the device or drivers. However, this might impact the branding of the device if
the Subsystem ID is used to select the device branding string.
Workaround:
None.
Status: B0=Yes, B1=Yes; NoFix

Source: https://cdrdv2.intel.com/v1/dl/getContent/331430?wapkw=x710 spec update  

0 Kudos
Azeem_Intel
Employee
782 Views

Hello Brad,

Greatings for the day

Hope you doing well Could you please share a snapshot of the defective part with the serial number visible? Additionally, I kindly request error snapshots related to the issue.

To address this matter effectively, it's important to delve deeper into the possible reasons behind this discrepancy. Understanding whether this is a hardware or configuration-related issue is crucial. Could you please provide a brief description of the issue for further context?


Beast Regards
Azeem

0 Kudos
brad_cve
Beginner
666 Views

Hello Azeem,

Apologies for the delay in responding. Attached is a photo....the serial is FLY2730062F. I pasted the error we encountered earlier.

 

Thanks,

Brad

IMG_2744.JPG

0 Kudos
brad_cve
Beginner
665 Views

Also worth noting, we have 14 nodes and 14 cards, all exhibiting the same issue on these cards.

0 Kudos
Azeem_Intel
Employee
708 Views

Hi Brad,


Greetings for the Day!


We are following up to find out if you were able to find the information we provided. Please reply to confirm, so we can continue helping on a resolution. Looking forward to receiving your reply.


Best Regards,
Azeem.

0 Kudos
Azeem_Intel
Employee
681 Views

Hi Brad_cve,



Greetings for the Day!



We are following up to find out if you were able to find the information we provided. Please reply to confirm, so we can continue helping on a resolution. Looking forward to receiving your reply.



Best Regards,

Azeem.


0 Kudos
Azeem_Intel
Employee
610 Views

Hi brad_cve,



Greeting for the Day!



I hope you are doing well. We kindly request that you share clear pictures of the product from both the front and back angles. Additionally, could you please confirm if you have 14 nodes? could you please also let us know from where these products were purchased?




Please do not hesitate in contact us, we are more than glad to assist you.



Best Regards,

Azeem_Intel


0 Kudos
Azeem_Intel
Employee
564 Views

Hi brad_cve,






Greetings for the Day!






We are following up to find out if you were able to find the information we provided. Please reply to confirm, so we can continue helping on a resolution. Looking forward to receiving your reply.






Best Regards,


Azeem_Intel


0 Kudos
Azeem_Intel
Employee
518 Views

Hi brad_cve,



Greetings for the Day!



We are following up to find out if you were able to find the information we provided. Please reply to confirm, so we can continue helping on a resolution. Looking forward to receiving your reply.


Please do not hesitate in contact us, we are more than glad to assist you.


Best Regards,

Azeem_Intel



0 Kudos
Azeem_Intel
Employee
477 Views

Hi brad_cve,



Greetings for the Day!



We are following up to find out if you were able to find the information we provided. Please reply to confirm, so we can continue helping on a resolution. Looking forward to receiving your reply.


Please do not hesitate in contact us, we are more than glad to assist you.


Best Regards,

Azeem_Intel


0 Kudos
Reply