Community
cancel
Showing results for 
Search instead for 
Did you mean: 
HHuyH
Beginner
674 Views

Driver for X520-SR2 Bypass Adapter

I tried downloading the 24_4 driver as suggested by ark.intel but it didn't work.

It's HWID in windows Server 2019: PCI\VEN_8086&DEV_155D&SUBSYS_00018086

 

0 Kudos
36 Replies
Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

Thank you for posting in Intel Ethernet Communities. 

 

Before we proceed, can you tell us if you are having the same error using a different OS?

Or have you tried different OS to check if you will get the same issue?

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
247 Views

I tried Centos 7, centos 8, Ubuntu 18.4 but they did not work :(

Modprobe ixgbe and nothing :(

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

Thank you for the confirmation.

 

Kindly provide a photo of the card on both side focusing on the markings for us to validate the card.

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
247 Views

Here is my card20200113_162504.jpg

20200113_162447.jpg

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

Thank you for sending the pictures of the card.

Here are my recommendations to troubleshoot or isolate the issue.

 

  1. Try to download the latest or you may also try 1 step lower driver version for your OS. Here is the download site: https://downloadcenter.intel.com/product/68674/Intel-Ethernet-Server-Bypass-Adapter-X520-SR2
  2. If still the same, it is time to isolate and check if the NIC is faulty. Try this NIC on a different system or try a different NIC on your system and check if that will work.

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
247 Views

I tried it on other systems but it didn't work.

I tried I350-T4, it works normally.

When analyzing INF in driver, I could not find any line containing Hardware ID "VEN_8086&DEV_155D". Does this adapter have no public driver? I have tried the versions 24_4, 24_3, 20_4 as well.

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

The link that I provided is already the drivers available in our download site for your Ethernet card.

That is the reason why aside from trying the drivers, I also asked to isolate the Ethernet card to check if the card is faulty.

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
247 Views

I mean, there is no specification in the driver for the X520-SR2 Bypass Adapter. No hardware ID matches the hardware id of the card.

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

Can you provide the link where you downloaded the driver for me to check?

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
247 Views

I download it from here: https://downloadcenter.intel.com/download/29320/Intel-Ethernet-Adapter-Complete-Driver-Pack

 

Opening all INFs, I couldn't find any description about HWID VEN_8086 & DEV_155D

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

Can you try this one? This is the latest driver for your card.

 

https://downloadcenter.intel.com/download/22283/Intel-Ethernet-Adapter-Complete-Driver-Pack?v=t

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
247 Views

I tried version 24_5. But when analyzing INF in driver, I didn't see HWID "VEN_8086 & DEV_155D"

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

The driver that I provided is the only available driver for your card. And also, since you already tried isolation test, there is a chance that the card is faulty.

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
247 Views

You don't understand what I mean?

In the driver you gave, it doesn't have the specification that corresponds to the HWID I have. This leads to a driver that cannot be installed.

Not a faulty card.

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

Can you provide the following details.

 

  1. What is your OS?
  2. How did you install the driver?
  3. Can you provide the screenshot of the error?

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

 

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

I just want to make a follow up on the information that I requested below:

 

  1. What is your OS?
  2. How did you install the driver?
  3. Can you provide the screenshot of the error?

 

If you have questions, please let us know.

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

I am just sending another follow up on the information that I requested. 

Since we have not heard back from you, We will close this inquiry now. 

If you need further assistance, please post a new question. 

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
247 Views

Sorry, we Vietnamese have just spent a long Tet holiday.

I use 2 ways as an Intel installation wizard and manually using Device Manager. I'm currently using Windows server 2019.

Michael_L_Intel2
Moderator
247 Views

Hello HHuyH,

 

Can you also provide the screenshot of the error during driver installation.

If you need further assistance, please post a new question. 

 

Best regards,

Michael L.

Intel Customer Support Technicians

A Contingent Worker at Intel

HHuyH
Beginner
175 Views

Annotation.png

Reply