Ethernet Products
Intel® Ethernet products and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
4264 Discussions

Dropped UDP Packets on Intel 82579V


I've been trying to solve an issue I've been having with an Intel 82579V on a Asus Rampage IV Extreme board. Whenever the NIC connects to a gigabit switch and negotiates to 1000/full, I'm seeing packet drops/network errors on a UDP streaming application. The packet drop can range from sporadic to extremely common. I've even witnessed occasions where the packet drops will not occur for several hours or even a day. A day or two later, the issue invariably shows up again. I'm running Win7 x64 with the generic Intel NIC drivers (using 17.4 but have also tried 17.3) and I'm running the latest available BIOS from Asus on the mobo (3404). I also did the NVM update as a shot in the dark. I've tried turning off all the power management settings as well as disabling Interrupt Moderation, TCP Offloading and the like. Nothing seems to work. The only surefire fix I have managed to find is setting the link speed to 100/Full. Then all packets are received without issue. I've isolated this to either the motherboard or the NIC. The reason I can say this with confidence is that I have tried the streaming application on other computers with various NICs and the issue does not show up at gigabit speeds (two of them are even Intel NICs although I forget the exact model right now). I've even gone so far as to try different un-managed gigabit switches and replacing the Cat6 cables. In the end, it's always my mobo with the 82579V that consistently shows this problem.

Ordinarily, I would just heed the advice I've seen on other posts and buy a dedicated NIC. Problem is, all my expansion slots are already taken up. And while setting the link speed to 100/Full is a good temporary solution in the short term, I will be needing the gigabit speeds in the near future.

The only thing I haven't tried is updating to the 18.0 driver package I saw online although I held off on it just because I wasn't sure if any changes were made for my NIC model.

0 Kudos
2 Replies



17.3 had the last driver change for your network connection, so upgrading to 18.0 won't help. On other threads people are reporting the issue is gone after a BIOS update. Maybe ASUS has a newer update coming soon. I would watch for another update or contact ASUS support directly.

Mark H