Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4986 Discussions

EXPI9402PT issues assigning static IP


I have a moderately complicated question - and I'm hoping someone can help me find an answer... I've searched the boards, but as I suspected - nobody is posting that they are doing exactly what I am trying.



- I have a EXPI9402PT (dual port server NIC), which I am using to support 2 seperate static IP Addresses on a Windows 7 Pro PC.


- I have a seperate network card, which uses DHCP to pull an IP from our corporate LAN when it is connected.


- All three ports are connected to a Gig-e switch.

Failure scenario:


When our corporate network (LAN) is connected to this switch and I bootup the PC - the EXPI9402PT network connections fail to establish their IP Addresses.

When it fails:


1) if I try to ping an address I get 'general failure'


2) if I run 'arp -a' - I get an empty table

I've found a workaround:


If I disconnect the LAN cable from the switch, and bootup the PC - then everything is fine. After bootup, I can plug in the LAN cable - and all three ports work correctly. This works, but not ideal. Does this mean the EXPI9402PT is trying to communicate with the LAN? It shouldn't be.

Disclaimer: If I use a different network card, in this exact same configuration - I don't have this problem. This is what leads me to think it could be a problem with the EXPI9402PT, or some configuration item which is specific to server NICs.

Anyone out there have any ideas? Thanks!!

0 Kudos
4 Replies

I tried something similar on bench PC. I have an EXPI9402PT with static IPv4 addresses configured on different class C networks and connected to the same gigabit switch at 1Gbps. The switch internal interface is on the same subnet as one of the two static ports, and pings are successful.

I also have a built-in network connection that is connected to our corporate network and receives address information via DHCP. The corporate switch is not the same switch as the two static ports and the connection is 100 Mbps/Full Duplex.

My OS is Windows 7 Ultimate, 64-bit.

All adapter settings and network connection settings are using default values (with the exception of the static IPv4 addresses on two ports.)

When I boot with all ports connected everything comes up and all ports work as expected without any general ping failures or empty arp tables.

I know of at least one likely difference that might matter here. The e1e driver used by the EXPI9402PT was just updated less than a week ago using the version 17.1 software. The driver is dated 03/07/2012 and is version

My recommendation is to update the software and drivers first. If that does not resolve the issue, then I would look next at any extra configuration or added services running on the PC to see what is different and try to narrow down the cause of the issue.

I hope this helps.

Mark H


Thanks for the input, that helped back up my theory that the card is functioning properly.

Since initially posting, I have built a cloned pc - which works as expected.

Then I moved it to the room where the problem was occuring, and it repeated.

Clearly, something is wrong with the network setup in that room.

0 Kudos

After further investigation, I don't really think anything is necessarily wrong with the network configuration of the room as I stated before.

I'm still battling this card, and wondering if anyone knows of a feature that is specific to this card - which can be disabled. I'll explain...

I also notice that there is an automatic configured ip address assigned in the 169.x.x.x range, in addition to the OS specified address when I workaround the problem. No idea how to turn this off, maybe a related symptom? I've tried disabling numerous registery keys, and no change observed.

I tried setting up custom firewall rules blocking all ports except the ones on my local static ip/subnet range. My thinking is that this prevents the OS from interfering. When I disable/re-enable the NIC, I get the same problem.

I can use other network cards, with the same static-ip configuration without problem. This leads me to wonder if this 'server NIC' has some special reliability features, that are in this case - undesirable.

0 Kudos

You wondered, "This leads me to wonder if this 'server NIC' has some special reliability features, that are in this case - undesirable." I am very familiar with these adapters, and I do not believe that any adapter feature is blocking this from working. By the way, on my test, I used all default settings except for the static IP addresses. I am assuming that you are using defaults too.

I do have one idea. Because you are getting one of the automatic IP addresses assigned to the ports, this means that Windows thinks the ports are configured for DHCP, not static IP addresses. First, maybe Windows is somehow applying a profile that thinks your static IP addresses only apply when you are connected to a particular network. Make sure the static IP addresses show in the properties when you are connected to the network with the failure.

Another possibility is that your TCP/IP property changes configuring the static IP addresses might be somehow corrupted in the registry. A possible workaround for that would be to:

  1. Uninstall the adapters using Windows Deivce Manager


  2. Restart Windows


  3. Configure the static IP address on one port, hit OK,


  4. Wait a full minute before configuring the static IP address for the second port.


The reason for the wait is because I have known Windows to take awhile to initialize a network connection's properties. If you make another change too soon, then the next change doesn't "take."

I don't know exactly what is happening in your case, so the above are ideas that might work to fix the problem. They are both things that I would try if I were in this situation.

Mark H

0 Kudos