Community
cancel
Showing results for 
Search instead for 
Did you mean: 
V_
Beginner
1,248 Views

Flow director rules not applied

Hi,

I'm trying to get my XL710 NIC to send packets to different queues but so far without any luck. I'm running Ubuntu with kernel version 4.16.1. I downloaded version 2.4.6 of the i40e driver from the Intel download center. Because my packets weren't arriving as expected I modified the driver to print the queue being cleaned and the incoming packets to dmesg. The commands I'm using to set up the rules are as follows:

sudo ethtool -N enp1s0f1 flow-type ip4 dst-ip 6.6.6.6 action 0

sudo ethtool -N enp1s0f1 flow-type ip4 dst-ip 6.6.6.7 action 1

ethtool -n enp1s0f1 confirms the rules have been set properly. However, when I check dmesg I can see the packets are not landing in the specified queues. I have tried different versions of the ethtool command such as -U instead of -N and tcp4 or udp4 instead of ip4. Any suggestions as to why this could happen?

0 Kudos
2 Replies
idata
Community Manager
52 Views

Hi Vedette,

 

 

Thank you for posting in Wired Communities. Can you try the driver from sourceforge website?

 

https://sourceforge.net/projects/e1000/files/i40e%20stable/

 

 

Please feel free to update me.

 

 

Regards,

 

Sharon T
idata
Community Manager
52 Views

Hi Vedette,

 

 

Have you tried the driver from sourceforge? Please confirm if this issue exist if you use other operating system? This will help us to better isolate the issue.

 

 

Regards,

 

Sharon T
Reply