Community
cancel
Showing results for 
Search instead for 
Did you mean: 
mradi1
Beginner
1,412 Views

Forwarding packets using XL710 network controller

Hi,

I have a XL710QDA2 40GB NIC and I also have the INTEL Ethernet QSFP+ cable. I have two problems:

1- This NIC does not get IPV4 address automatically. What should I do to force it to get IPV4 address upon boot?

2- I have tried to send packets through this NIC to other devices, but it can not forward any packet (IPV4, IPV6, or even broadcast packets). How can I enable the packet forwarding and receiving of this NIC?

Thanks for your time. I would appreciate it if you could help me out.

Best,

Marjan

0 Kudos
6 Replies
idata
Community Manager
63 Views

Hi Marjan,

 

 

Thank you for posting in Wired Communities. Can you clarify information below, so that I can better check for you.

 

1) Please confirm which Intel Ethernet QSFP+cable you used based on the product brief at https://www.intel.com/content/www/us/en/ethernet-products/optics-cables/ethernet-qsfp-cables-brief.h...

 

 

2) What is the operating system?

 

3) How did you configure the IP setting? Did you configure it obtain IP address automatically (if you are using Windows OS) and connect to a DHCP server?

 

4) Please provide more information about your setup e.g. which device this XL710QDA2 is connected to.

 

 

Looking forward to your reply. Thank you.

 

 

Regards,

 

Sharon T
mradi1
Beginner
63 Views

Hi Sharon,

Thanks for your message.

1) My Ethernet QSFP+ cable is based on the product brief (Intel Ethernet QSFP+, XLDACBL# ).

2) My OS is Ubuntu 16.4

3) Now it is set to obtain IP address automatically. But it does not get any. when I issue ifconfig command it shows that it just has IPv6 address.

4) It is connected to an Ubuntu PC and the i4e driver is loaded properly and the NIC's lights are up, which means it is ready to use. But I do not why I can not send packets through it using Scapy software.

Best,

Marjan

idata
Community Manager
63 Views

Hi Marjan,

 

 

Thank you for the information. Please refer to information below:

 

 

1) Please ensure your Ubuntu PC connects to a DHCP server which can allocate IP address.

 

 

2) Is this the driver you installed? https://downloadcenter.intel.com/download/24411/Intel-Network-Adapter-Driver-for-PCIe-40-Gigabit-Eth...

 

 

3) Have you tried assigning static IP address?

 

 

4) Which port did you see when you run the ifconfig? Eth0 or Eth1?

 

 

5) Please try referring to the steps in our README file about the driver installation at https://downloadmirror.intel.com/24411/eng/readme.txt

 

 

Refer to the Building and Installation section. ( I have extracted here for your reference:)

 

To build a binary RPM* package of this driver, run 'rpmbuild -tb

 

i40e-.tar.gz', where is the version number for the driver tar

 

file.

 

 

Note: For the build to work properly, the currently running kernel MUST match

 

the version and configuration of the installed kernel sources. If you have just

 

recompiled the kernel reboot the system before building.

 

 

 

Note: RPM functionality has only been tested in Red Hat distributions.

 

_lbank_line_

 

 

1. Move the base driver tar file to the directory of your choice. For

 

example, use '/home/username/i40e' or '/usr/local/src/i40e'.

 

 

2. Untar/unzip the archive, where is the version number for the

 

driver tar file:

 

tar zxf i40e-.tar.gz

 

 

3. Change to the driver src directory, where is the version number

 

for the driver tar:

 

cd i40e-/src/

 

 

4. Compile the driver module:

 

# make install

 

The binary will be installed as:

 

/lib/modules//updates/drivers/net/ethernet/intel/i40e/i40e.ko

 

 

The install location listed above is the default location. This may differ

 

for various Linux distributions.

 

 

NOTE: To gather and display additional statistics, use the

 

I40E_ADD_PROBES pre-processor macro:

 

# make CFLAGS_EXTRA=-DI40E_ADD_PROBES

 

Please note that this additional statistics gathering can impact

 

performance.

 

 

5. Load the module using the modprobe command:

 

modprobe [parameter=port1_value,port2_value]

 

 

Make sure that any older i40e drivers are removed from the kernel before

 

loading the new module:

 

rmmod i40e; modprobe i40e

 

 

6. Assign an IP address to the interface by entering the following,

 

where ethX is the interface name that was shown in dmesg after modprobe:

 

 

ip address add / dev ethX

 

 

7. Verify that the interface works. Enter the following, where IP_address

 

is the IP address for another machine on the same subnet as the interface

 

that is being tested:

 

ping

 

 

Note: For certain distributions like (but not limited to) RedHat Enterprise

 

Linux 7 and Ubuntu, once the driver is installed the initrd/initramfs file may

 

need to be updated to prevent the OS loading old versions of the i40e driver.

 

The dracut utility may be used on RedHat distributions:

 

# dracut --force

 

For Ubuntu:

 

# update-initramfs -u

 

 

Please feel free to update me.

 

 

Thanks,

 

Sharon T
idata
Community Manager
63 Views

Hi Marjan,

 

 

Please feel free to provide the information requested and if you have tried the suggestion.

 

 

Thanks,

 

Sharon T
idata
Community Manager
63 Views

Hi Marjan,

 

 

Please help clarify if you encountered similar issue with other means of connectivity test like PING? Since you mentioned cannot send packet using Scapy software which we want to know if this only occur if using Scapy software.

 

 

Let me know also if you have tried assigning static IP and if this will work.

 

 

Thanks,

 

Sharon T

 

idata
Community Manager
63 Views

Hi Marjan,

 

 

Please feel free to provide the information.

 

 

Thanks,

 

Sharon T
Reply