Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
920 Views

Freebsd 9.x - Wake on Lan not working

Hello,

I ran into the problem that wake on lan is not working with freebsd and intel nic.

Shutdown the system with poweroff, WOL is not working.

if I comment out

/sbin/ifconfig -l | /usr/bin/xargs -n 1 -J % /sbin/ifconfig % down

in /etc/rc.shutdown, wake on lan is working.

the catch - after the reboot, the interface doesn't react (no IP - not even static - can be assigned). I've to poweroff the machine again (with ifconfig down) for the interface to work again.

Port LEDs stay on - with and without ifconfig down.

Thanks,

Andreas

Here are the details:

FreeBSD 9.2-RELEASE-p3

em0: flags=8843 metric 0 mtu 1500

options=4219b

ether 00:15:17:31:XX:XX

inet 172.17.0.6 netmask 0xffffff00 broadcast 172.17.0.255

nd6 options=9

media: Ethernet autoselect (1000baseT )

status: active

em0: port 0xbc00-0xbc1f mem 0xff6e0000 0xff6fffff irq 16 at device 0.0 on pci1

em0: Using an MSI interrupt

em0: Ethernet address: 00:15:17:31:XX:XX

0 Kudos
1 Reply
idata
Community Manager
53 Views

Retested with FreeBSD 10.0 - Wake on Lan works.