Community
cancel
Showing results for 
Search instead for 
Did you mean: 
XSun10
Novice
2,496 Views

Gigabyte Z97-D3H+Intel X520-SR2 fail to enable VFs

Jump to solution

Hi, I try to create VFs with Intel X520-SR2 on Gigabyte Z97-D3H.

I enable Intel Virualization Technology and VT-d in BIOS setting and add boot parameter "intel_iommu=on".

I use PF driver (ixgbe driver version: 4.0.3) and VF driver (ixgbevf driver version: 2.16.1) on Ubuntu 14.10 with kernel version of 3.16.0.23

After insert ixgbe and ixgbevf module, I fail to see VFs with lspci -n command.

Can anybody help me? Thank you!

0 Kudos
1 Solution
XSun10
Novice
641 Views

Add boot parameter: pci=assign-busses

Then VFs can be seen.

Thank you!

View solution in original post

4 Replies
ANDREY_V_Intel1
Employee
641 Views

Are you enabling VFs on your system?

You should load the driver with sriov_numvfs parameter like this:

echo 4 > /sys/class/net/device name/device/sriov_numvfs

Please refer to the SR-IOV configuration guide for more details: http://www.intel.it/content/dam/www/public/us/en/documents/technology-briefs/xl710-sr-iov-config-gui... http://www.intel.it/content/dam/www/public/us/en/documents/technology-briefs/xl710-sr-iov-config-gui...

XSun10
Novice
641 Views

Hi, Anvanster, thank you for your reply

I did try to enable VFs as you described, echo 4 > /sys/bus/pci/devices/0000\:05\:00.0/sriov_numvfs

but I met the following error in terminal.

write error: cannot allocate memory

Dmesg will show: SR-IOV: bus number out of range.

I tried to add "pci=realloc=on/off" to boot parameters, but still met this error.

XSun10
Novice
642 Views

Add boot parameter: pci=assign-busses

Then VFs can be seen.

Thank you!

View solution in original post

ychen105
Beginner
641 Views

hi , i'm confused with the same question as you describe ,however i can't create it correctly . could you help with some further instruction? my email is mailto:enwplan001@163.com enwplan001@163.com

Reply